Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Why can't I modify files on ubuntu when I am connecting with

I'm using the latest version and on Windows 7 via SFTP protocol

I've tried different ways and read some solutions including these:
Why I am not able to ssh as root?
Editing with Winscp
And an article from this Forum of

I don't understand why when I connect with ubuntu via putty, I can have root permission and modify files. However, when I connect with ubuntu via WinSCP, I'm another user(I used the same username and same private key(pem) on both connecting software) and can't modify files.

Then I found some possible solutions from the links above. I tried to set root password and permitRootLogin. But then, when I log in with the root username, it says the file is too big, whereas when I changed the username back to ubuntu, then it works(file is size has no problem, but I can't modify files when I'm not root user).

I am very confused, please anybody if you can point me out, I'd be much appreciated.