Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: ... solved: resolve symbolic links not set

Thanks for sharing your solution!

... solved: resolve symbolic links not set


generatead manually a new 'site':

no special settings, just URL and username.

=> double click on a file works fine: opens the file in the desired application

-> compared all the settings accessible via session-edit-advanced with the settings of the 'site' which works not properly

=> resolve symbolic links in environment-directories is not set

-> setting this solves the problem: double click opens file

but there is no symbolic link here on the server side !

In the web-doc if find under directory_reading_options
the following sentence:

Also when the resolving is disabled or not supported, double-clicking on any remote file will be interpreted as an attempt to open the directory with the same name.


open with doubleclick gives error 2

I could not find a similar report on your pages so i post it here:

I have access to a distributed linux file system

If i try to open a file via doubleclick
winscp tries to open a directory with the same name
which does not exist ...
and an error 2 (file not found) occurs:

Datei oder Verzeichnis nicht gefunden.
Fehlercode: 2
Fehlernachricht vom Server : No such file


basil_iwv.png;-;24837;2014-03-27T21:27:25.000Z;"uname" [XXXXX];"users" [YYY];rw-r--r--;0
Changing directory to "basil_iwv.png".
Getting real path for '/.../basil/basil_iwv.png'
Type: SSH_FXP_REALPATH, Size: 57, Number: 34064
Type: SSH_FXP_STATUS, Size: 24, Number: 33796
Discarding reserved response
Type: SSH_FXP_NAME, Size: 117, Number: 34064
Real path is '/.../basil/basil_iwv.png'
Trying to open directory "/.../basil/basil_iwv.png".
Type: SSH_FXP_LSTAT, Size: 57, Number: 34311
Type: SSH_FXP_ATTRS, Size: 37, Number: 34311
Getting current directory name.
Listing directory "/.../basil/basil_iwv.png".
Type: SSH_FXP_OPENDIR, Size: 57, Number: 34571
Type: SSH_FXP_STATUS, Size: 29, Number: 34571
Status code: 2, Message: 34571, Server: No such file, Language:
(ECommand) Fehler beim Anzeigen des Verzeichnisses "/.../basil/basil_iwv.png".
Datei oder Verzeichnis nicht gefunden.
Fehlercode: 2
Fehlernachricht vom Server : No such file

If i use the right mouse button the command 'open' works fine.

If i access the filesystem via another machine double click works fine.

double click is configured as 'open'
and winscp should use the standard program of windows.

version is 5.5.6, transfer is sftp, i am using GUI (..yes doubleclick) as explorer
language is german.

thanks for having a look onto it.