Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

ports wrote:

The funny thing is that I don't have any problems if I'm going to copy
those files via pscp from my windows machine where winscp is running
and showing me that problem.

It may be caused by the fact the WinSCP must open shell on remote server while command-line clients does not. It probably changes processing of commands.

I would suggest you to try to specify /bin/bash shell on SCP tab of login dialog or use SFTP instead of SCP.
ports

Hi,

sorry for the delay. Now here's a log from winscp. That's the part if I
try to copy the file for the first time.

. Copying 1 files/directories to local directory "C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\"
. PrTime: Yes; PrRO: Yes; Rght: rw-r--r--; PrR: No; FnCs: N; RIC: Yes; Resume: S (102400); CalcS: Yes; Mask: *.*
. TM: M; ClAr: No; ExclM:
. AscM: *.*htm*; *.txt; *.php*; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
> echo "WinSCP: this is begin-of-file" ; scp -r -p -d -f "110_R_ZR04D082252_06122004_0803.txt" ; echo "WinSCP: this is end-of-file:$status"
< WinSCP: this is begin-of-file
. Sending NULL.
! invalid characters in scp command!
! here:R04D082252_06122004_0803.txt"
! try using a wildcard to match this file/directory
< WinSCP: this is end-of-file:-1
* (ECommand) Copying files from remote side failed.
* Cannot execute SCP to start transfer. Please make sure that SCP is installed on the server and path to it is included in PATH. You may also try SFTP instead of SCP.
*

And now the part where I try to copy the file for the second time.


. Copying 1 files/directories to local directory "C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\"
. PrTime: Yes; PrRO: Yes; Rght: rw-r--r--; PrR: No; FnCs: N; RIC: Yes; Resume: S (102400); CalcS: Yes; Mask: *.*
. TM: M; ClAr: No; ExclM:
. AscM: *.*htm*; *.txt; *.php*; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
> echo "WinSCP: this is begin-of-file" ; scp -r -p -d -f "110_R_ZR04D082252_06122004_0803.txt" ; echo "WinSCP: this is end-of-file:$status"
. Server sent command exit status 1
. All channels closed. Disconnecting


The funny thing is that I don't have any problems if I'm going to copy
those files via pscp from my windows machine where winscp is running
and showing me that problem.
I really would appreciate any good idea to solve that problem ;)

regards
martin

Re: Connection lost/filename with special characters

Either post full log or try SFTP protocol, instead of SCP.
ports

Connection lost/filename with special characters

Hi,

today I noticed a strange effect. My goal was to copy some files to a
remote solaris box. In this solaris environment we just have a chroot
with the ability to copy files via sftp/scp.
A few files used special german characters like (ae), (oe), (ue).
If I try to copy a file with a special character I get the following
error message:

Copying files from remote side faild.
Cannot execute SCP to start transfer. Please make sure that SCP is installed on the server and path to it is included in PATH. You may also try SFTP instead of SCP.


If I'll try again to copy the file the next error message appears:


Copying files from remote side failed.
Connection has been unexpectedly closed. Server send command exit status 1.


At next WinSCP drops the connection and I have to reconnect. Any ideas?

Regards :)