Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review



1. I connect to the server once from the GUI, so that the host's key is stored in the host key cache (using .ini storage).

2. I use the /ini option. I copy the .ini file from the WinSCP3 directory int a directory accessible to the job user. It now contains the relevant host key (see step 1).

3. Now the script runs okay when started by the job user account.

4. There are still errors due to permissions and time-stamp. Since I don't want the lose the time-stamp information, I did not want to disable these options. I was able to change the permissions on the target folder on the server so that the errors no longer occur. I also have the script delete (rm) the remote file before put-ing the new version.

Thanks for the link to the FAQ entry - I did a search before posting but did not find that entry.

1. This script is running as a scheduled job. If I change the relevant options in the GUI, what do I need to do to make sure they will affect the console script?

2. Do I need to change the GUI so that it stores the settings in an .ini file? If so, can you please tell me where I can find an example .ini file - I looked in the WinSCP3 directory but didn't find one.

Re: timestamp and permissions error - disable in script ?

newbie wrote:

a) tell me what the problem might be, and

Please read FAQ.
b) tell me how to disable the relevant options ?

It can be disabled from GUI only.

timestamp and permissions error - disable in script ?

I get the following error when running a schedule script file. I am not sure what is causing the problem. I do not know how I can turn off the permissions or the timestamp changes from withing the script or from the command line. Can you please:
a) tell me what the problem might be, and
b) tell me how to disable the relevant options ?

The command I run looks like this (I have changed paths and filenames below):

winscp3 /console /script=uuu.txt

Upload of file '' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn off 'Set permissions' and/or 'Preserve timestamp' option.
No such file or directory.
Error code: 2
Error message from server: syserr: No such file or directory, file: yyy\ (en)
Request code: 9
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort
Session 'zzz@vvv' closed.
No session.

Thank you - your software has been very helpful so far.