Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Hi Martin,

I tried putting a timeout value in SessionOptions and it got to 99% but just hung in there for a while so I decided to kill it. I then upgraded to the latest version of WinScp(5.9.4) and not only did it finish the upload but the transfer speed increased from an average of 3 MB/s to 16 MB/s! I didn't realize I was out of date until I compared my version. Thanks for your help!

Re: Upon near upload completion WinScp times-out and restarts the upload

Did you try setting a longer timeout? SessionOptions.Timeout

Also, please upgrade to the latest version of WinSCP.

Upon near upload completion WinScp times-out and restarts the upload

I'm having timeout issues when using the .NET assembly on a remote server that's running on Windows Server 2012 R2 Datacenter. I tried to reproduce the issue with the same file (when you read the logs files it's the same file just different names) on my local machine that's running Windows 10 Pro but the upload succeeds without a problem. The problem occurs when the upload process is about at 99.9% complete, it pauses for several seconds and begins the upload process again from 0%. I tried increasing the session/transfer options timeout and it did not resolve it.

Attached I have a zip file with 4 files (2 each for debug/session on my local and remote hosts) and I renamed some sensitive information such as username and password to something generic. Also I have the following questions/comments:

1. I specify the transfer mode to be Binary before I begin the upload process but looking at the logs it starts as ASCII and then in the middle of the process switches to binary, what is the reason it is doing this?
2. This issue seems to only happen with large files near 5GB with this server, however if I send smaller files in MBs it does not occur. Could this be a timeout issue and I'm just setting the wrong value in the .NET library?
3. How come the upload starts again even though I explicitly state to turn off the TransferResume feature that WinSCP offers?

Any help will be greatly appreciated.