Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Some details added

Batch file contents:
winscp.exe /console /script=l4r.txt

Script l4r.txt contents, an example:
open ovh
option confirm off
synchronize remote "c:\Kä\" "Backup/"

These are in WinSCP directory.


The version I have: 5.9.6

Problem with local end directories involving scandinavian characters

Hello. I've been using WinSCP for file backup off my two Windows PCs for some time, I've used a batch file which is started timed by the Windows' task center. I recently wanted to make also backup of the "Documents" and "Pictures" folders that Windows has in its disk directory. Unfortunately the other PC is set for Finnish language, so the full local path becomes something like c:\Käyttäjät\Käyttäjä\Documents, which includes scandinavian characters. The script file which the batch file refers to is written including those scandinavian characters, of course. The problem is that the batch transfer will never start; obviously due to those special characters in the local disk path. I also tried making a dedicated folder under c: which had those characters. The same result; the batch job will not execute. Yet, using WinSCP's commander view with local + remote directory views, the files/folders transfer with the mouse click just perfectly; the local section's special characters in folder names are seen exactly as they appear in Windows' directory! I've used WinSCP with the defaults, and for the session I have used FTP, port 21, insecure. I’ve tried switching WinSCP languages between English and Finnish. I must have some terrible black hole in my understanding of WinSCP, I've not used it in other connections, this is the only and one time I've seen the product. What can I do? Is this a no-go? I tried to find a similar case in the FAQ, but didn't find, so I wrote this as a new post.