Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Hi again,

Answering to myself.

I found in sshd.log on the WIN10 machine:
error: Couldn't create pid file "./": Permission denied

So I ran in administrator powershell
.\FixHostFilePermissions.ps1 -Confirm:$false

And then everything works!

Sorry for disturbance.

Cannot connect to a WIN10 machine


I try to connect to a freshly installed WIN10 (home edition) machine using WinSCP.

The machine can be pinged, I can open a remote desktop on it.
Services ssh-agent and sshd are running on it.
SSH is allowed in firewall input traffic rules.

From this machine I can connect to other machines with WinSCP but I cannot connect to it...

I have tried all protocols:
- With SFTP and SCP: Network Error - Software caused connection abort
- With FTP: Timout

Last lines of full debug log using SCP protocol are:
. 2017-08-02 11:12:26.612 Enumerating network events for socket 1292

. 2017-08-02 11:12:26.612 Enumerated 32 network events making 32 cumulative events for socket 1292
. 2017-08-02 11:12:26.612 Handling network close event on socket 1292 with error 10053
. 2017-08-02 11:12:26.612 Selecting events 0 for socket 1292
. 2017-08-02 11:12:26.612 Network error: Software caused connection abort
* 2017-08-02 11:12:26.651 (EFatal) Network error: Software caused connection abort

Any idea ?