Post a reply :: Support Forum

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Command Line Inteface Question

See Set defaults button on stored sessions tab of login dialog.
Simon Tse

Re: Command Line Inteface Question

martin wrote:

Tom Williams wrote:

If I just ignore this prompt, will my script continue to completion and the shell will exit on its own?

Yes it should.

If the answer to number 1 is No, how to I prevent this prompt from showing? When I set Batch Mode On the script auto exits on the first prompt which is bad..

You can set longer timeout on login dialog.


I set a 999 timeout on the login dialog. But that doesn't actually save it does it? I have to save the 999 timeout to a specific session it seems like.

When I run the batch script to connect to a server, it still says timeout after 15 seconds. How can I set the default timeout to be higher so that the command line batch script for winscp can have a long timeout as well?
martin

Re: Command Line Inteface Question

Tom Williams wrote:

If I just ignore this prompt, will my script continue to completion and the shell will exit on its own?

Yes it should.

If the answer to number 1 is No, how to I prevent this prompt from showing? When I set Batch Mode On the script auto exits on the first prompt which is bad..

You can set longer timeout on login dialog.
Tom Williams

Command Line Inteface Question

When I am running long shell scripts on the server, I see a prompt that the server has not communicated back in 15 seconds with an option to abort or wait another 15 seconds.

Question 1
If I just ignore this prompt, will my script continue to completion and the shell will exit on its own?

Question 2
If the answer to number 1 is No, how to I prevent this prompt from showing? When I set Batch Mode On the script auto exits on the first prompt which is bad..

I'm using the December posting of WinSCP.

Regards,

Tom