Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Yes, that worked. Thank you.

Using Costura.Fody generates assembly missmatch

In a new project in Visual Studio 2017, WinSCPnet v5.15.3 is downloaded from Nuget Package Manager everything is working smoothly. I installed Costura.Fody v3.3.3 so that every dll is embeded in the .exe file for easier distribution and when it runs I get the error

"The version of C:\path_to_project\bin\Debug\winscp.exe ( does not match version of this assembly C:\path_to_project\bin\Debug\SFTPUploader.exe ("

I worked around this error by excluding WinScpnet assembly in the FodyWeavers.xml like this

I dont know if this is a problem in winscpnet or costura.fody but do you know how to solve it?