Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: WinSCP keeps on disconnecting when transferring large files (over 500KB)

Can you do a packet capture (e.g. using Wireshark)?

Please report the code generation problem to Wine.

I also have noticed that script generation function doesn't work properly under Wine. It misses function names.

So, instead of showing "open ftpes://xxx", it shows " ftpes://", the same for "put *" => " *", "lcd <dir>" => " <dir>" etc.

The same for Batch, PowerShell, .NET Assembly code.

I guess that there's some internal error that WinSCP doesn't show in logs.

Re: WinSCP keeps on disconnecting when transferring large files (over 500KB)

martin wrote:

Can you try (just for a test) decrease TLS version to 1.1 in WinSCP configuration?

Just tried, getting all the same.

Re: WinSCP keeps on disconnecting when transferring large files (over 500KB)

Can you try (just for a test) decrease TLS version to 1.1 in WinSCP configuration?


It'd be awesome to get at least a clue...

As long as I use automated script for deployment, I really need a viable solution for this, becuase for now the only solution is to run FTP under my system without TLS, which breaks all the security...

P. S.

I can't afford SSH/SFTP as well due to my server limitations.

WinSCP keeps on disconnecting when transferring large files (over 500KB)

I run WinSCP under Ubuntu 18.04 + Wine.

Everything works smoothly on SFTP, and FTP without TLS, but when it comes to FTPS, for some reason WinSCP disconnects on transferring files larger than approximately 500KB. After that, it offers to reconnect and transfers another 500KB. So for transferring a file of 3MB, I have to click "Reconnect" 6 times, which makes working with website quite difficult.

WinSCP log:

. 2020-04-15 13:27:45.688 File: 'wp-content\themes\Avada\includes\lib\assets\fonts\fontawesome\webfonts\fa-solid-900.svg' [2020-04-14T02:51:28.105Z] [849145]

. 2020-04-15 13:27:45.689 Copying "wp-content\themes\Avada\includes\lib\assets\fonts\fontawesome\webfonts\fa-solid-900.svg" to remote directory started.
. 2020-04-15 13:27:45.689 Binary transfer mode selected.
. 2020-04-15 13:27:45.691 Starting upload of wp-content\themes\Avada\includes\lib\assets\fonts\fontawesome\webfonts\fa-solid-900.svg
> 2020-04-15 13:27:45.691 TYPE I
< 2020-04-15 13:27:45.702 200 Type set to I
> 2020-04-15 13:27:45.702 PASV
< 2020-04-15 13:27:45.710 227 Entering Passive Mode (83,220,170,106,142,142).
> 2020-04-15 13:27:45.714 STOR fa-solid-900.svg
. 2020-04-15 13:27:45.715 Connecting to ...
< 2020-04-15 13:27:45.730 150 Opening BINARY mode data connection for fa-solid-900.svg
. 2020-04-15 13:27:45.739 Session ID reused
. 2020-04-15 13:27:45.740 Using TLSv1.2, cipher TLSv1.2: ECDHE-RSA-AES256-GCM-SHA384, 1024 bit RSA, ECDHE-RSA-AES256-GCM-SHA384 TLSv1.2 Kx=ECDH     Au=RSA  Enc=AESGCM(256) Mac=AEAD
. 2020-04-15 13:27:45.740 TLS connection established
. 2020-04-15 13:27:45.821 Disconnected from server
. 2020-04-15 13:27:45.821 Copying files to remote side failed.
. 2020-04-15 13:27:45.821 Connection was lost, asking what to do.
. 2020-04-15 13:27:45.821 Asking user:
. 2020-04-15 13:27:45.821 **Lost connection.** ("Disconnected from server","Copying files to remote side failed.")
< 2020-04-15 13:27:45.821 Script: Lost connection.
< 2020-04-15 13:27:45.823 Script: Disconnected from server

< 2020-04-15 13:27:45.823 Copying files to remote side failed.


mod_tls/2.6: unexpected OpenSSL error, disconnecting

notice: user aborting transfer: Data connection closed

ProFTPD mod_tls log:

2020-04-15 10:27:47,373 mod_tls/2.6[32549]: panic: SSL_ERROR_SSL, line 4935: 

  (1) error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

I tried transfer the same files with the same FTPS connection under FileZilla, it works perfectly. Because I'm running Ubuntu under VirtualBox, I had ability to check this issue outside Ubuntu (Windows 10), no problems are found.

Could anybody advise me something on my issue?

I checked Ubuntu firewalls, but ufw is disabled and iptables has no rules at all. Also, as I said, it works perfectly smoothly in FileZilla, so I'm sure it has something to do with WinSCP.

Or maybe with Wine, but I checked everything I could on this topic regarding Wine, and discovered only the fact that Wine never uses additional firewall, so everything that is getting blocked under Wine is blocked by superior OS, not by Wine environment.