Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review



Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, set Session.SessionLogPath. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.


I have been using WinSCP in a script to download files each morning for a number of years, has worked great. Until this weekend when the company on the server side upgraded their server and after making the necessary changes I get a Disconnected: Server protocol violation: unexpected SSH2_MSG_UNIMPLEMENTED packet response when trying to perform the $session.Open($sessionOptions) line in my PowerShell script.

Doing my research I find that this error seems related to the Key Exchange Algorithm but I can't find anything on how to adjust this algorithm in code.

I reached out to the company we are working with and they informed me that the new server uses the ssh-rsa key, 2048-bit and they provided me with the fingerprint.

So I replaced this fingerprint in my script file:
$sessionOptions.SshHostKeyFingerprint = "ssh-dss 2048 <thekey>"
$sessionOptions.SshHostKeyFingerprint = "ssh-rsa 2048 <newkey>"

I entered the new host name and password they provided. Username remained the same.

Note that the host name, username and password combination all word in a competing FTP application.

So what am I missing? I also ran the WinSCP console and receive the same error message.

Any thoughts?

Thanks in advance!