Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


As you can see in the log file, your server seems not to support preserving the timestamp and/or setting permissions.

Re: SFTP error while setting permissions and/or timestamp

Hi Martin,

Thanks for the link. I have read it yesterday, but I tried the IgnorePermissionErrors flag and it did not work.

But, when I used the -nopreservetime -nopermissions switches, it worked like a charm.

Do you know what may be not allowing winscp to preserve the timestamp? As I said before, I'm using a WS_FTP server and if there is something I can change on the server to allow winscp to preserve timestamp will be even better.

Thanks again for the quick response.

Best Regards,

Pedro Reys

Re: SFTP error while setting permissions and/or timestamp

Please read FAQ. If that does not help, come back.

SFTP error while setting permissions and/or timestamp


I've used WinSCP for a while due to its great scripting support. This time I'm trying to connect to a new SFTP server that we just built using WS_FTP.

Every time I transfer a file to that server using WinSCP, using scripting or the UI, I got an error saying the upload of the file was successful, but [url]error occurred while setting permissions and/or timestamp[/url].

As suggested by the error message I turned on the 'Ignore permissions errors' but the problem persisted.

I was using the 4.1.9 version of WinSCP. I then upgraded to the latest version, 4.2.9, and still have the same problem.

The log can be viewed here:

Just out of curiosity, I tried to transfer the file using Filezilla UI and it worked fine.

Best Regards