How do I paste a file in to the remote window?

Advertisement

Sopor
Sopor avatar
Joined:
Posts:
60
Location:
Sweden

How do I paste a file in to the remote window?

If I copy a file from File Explorer by right clicking on it and select copy and I then try to paste it in to WinSCP remote side it won't show Paste in the menu. To get Paste I need to scroll to the end and right click below all the files. Not very user friendly.

I'm using 5.21 now but in previous versions this was possible by clicking to the right of the name column.

So, how do I bring up the context menu and paste a file without scrolling to the end?

I know there are other ways to paste, but I want to continue to right click and select Paste when I copy a file from File Explorer to remote.

Reply with quote

Advertisement

Sopor
Sopor avatar
Joined:
Posts:
60
Location:
Sweden

I'm now at 5.21.6 and again I can't right click and paste in from my clipboard.

I do have "Full row select" enabled but if one row is selected I have been able to right click on another row to show the context menu and to show paste. This is not working anymore.

Maybe you could show Paste if I right click in the path (current directory) row at the top?

I want to be able to use the context menu and paste in files and still have full row select enabled.

I have attached a picture from an older version and here you can see that I can right click and use Paste from the context menu.

Description: Context menu with paste when full row select is enabled

winscp-rightclick.png

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,551
Location:
Prague, Czechia

What older version?

I've tested it now in 5.21.6. It seems to work like this (in Full row select mode).

Right-clicking:
  • the selected or focused item line shows file(s) context menu;
  • a text in not-selected item shows file(s) context menu;
  • empty space below the last file shows folder context menu;
  • empty space to the right of the last panel column shows folder context menu;
  • empty space to the right of any left aligned column in not-selected item line shows folder context menu;
I believe the last point is what your screenshot shows. And it still behaves like that even in 5.21.6.

Reply with quote

Advertisement

Sopor
Sopor avatar
Joined:
Posts:
60
Location:
Sweden

I have attached two videos. One from 5.21.6 and the other one is fro 5.19 but i know it has worked like this is some earlier versions of 5.21.x. I only found an old WinSCP in my portable directory and it was 5.19.x.

You can see that when i right click the selection will move to that file and it won't show paste in the context menu.

In the other video the selected video gets unselected, but the selector will stay on the file at this will show the paste.

I know i can go to the end and right click on an empty space, but that is not very user friendly.

That is why i suggested that i right click in the light blue bar that shows current directory.
Description: WinSCP 5.19.x
Description: WinSCP 5.21.6

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
40,551
Location:
Prague, Czechia

In your "new" video, the selection changes with the click. That's why the file context menu shows. But I have no idea why the selection changes. I cannot reproduce that. It behaves like if you click both left and right mouse button.

I'm not sure this is about version. Cannot it be about different machine/environment or different configuration?

Reply with quote

Sopor
Sopor avatar
Joined:
Posts:
60
Location:
Sweden

The behavior you see in the "new" video was the reason i created this post in the first time. Then after an update from 5.21 to 5.21.1 it was gone and it worked as in the "old" video, but now it seems to be back again in 5.21.6.

I haven't changed any settings for years in WinSCP and I can assure you that I'm not clicking on both mouse buttons at the same time 🙂

Reply with quote

martin
Site Admin
martin avatar

For me it behaves like in the "old" video in all of 5.21, 5.21.1, 5.21.5 and 5.21.6.

So if you now run 5.21.5 and 5.21.6 side-by side (with the same configuration), would they behave differently?

Reply with quote

Advertisement

Sopor
Sopor avatar
Joined:
Posts:
60
Location:
Sweden

I updated to 5.21.7 and now it is working again.

Hm, I'm wondering if this has to do with how long time WinSCP has been running?
Next time I notice this behavior I will try to restart WinSCP and see if that helps.

You see, I start WinSCP and then it will run for several weeks sometimes month before I restart it.

I restart WinSCP when I reboot my computer or update WinSCP.
My last reboot was more than two month ago 😊

Reply with quote

Advertisement

You can post new topics in this forum