can WinSCP handle ( and cope ) with the SETGIT BIT!?

Advertisement

unleash
Joined:
Posts:
4

can WinSCP handle ( and cope ) with the SETGIT BIT!?

hello dear friends



am a newbi so do not bear with me! I run a linux sever that is administered by a friend of me. He prepares the chown and permissins - with the setgit-bit to on.


Well the trouble is that i get lost the setgitbit every time when i touch the permissions with FileZilla. Filezilla cannot handle the Setgit-bit. that i know allready

That is the terrible issue! Note - at the moment i do not have a access to the server with WinSCP -
since i have not a windows-machine but a opensuse-linux.

question: can WinSCP handle ( and cope ) with the SETGIT BIT!? as far as i know, winscp can set the Setgit. Filezilla cannot do this at all!

love to hear from you
greetings unleash

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,442
Location:
Prague, Czechia

Re: can WinSCP handle ( and cope ) with the SETGIT BIT!?

Yes WinSCP does support it. Note that some SFTP server actually handle it incorrectly though. So it may not be Filezilla's fault after all.

Reply with quote

unleash
Joined:
Posts:
4

hello and good evening

,many many thanks for the quick reply - great to hear from you!!

i am a strong believer - and i guess you are right!!! Well here my settings:

on openSuse Linux server My Setup: OpenSuse 11.4 on the local machine! Linux- Server
FileZilla Client
----------------
Version:          3.3.4.1
Build information:
  Compiled for:   i686-pc-linux-gnu
  Compiled on:    i686-pc-linux-gnu
  Build date:     2011-02-23
  Compiled with:  gcc (SUSE Linux) 4.5.1 20101208 [gcc-4_5-branch revision 167585]
  Compiler flags: -fomit-frame-pointer -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector 
- funwind-tables -fasynchronous-unwind-tables -g -fstack-protector -Wall -g -fexceptions

Linked against:
  wxWidgets:      2.8.11
  GnuTLS:         2.8.6

Operating system:
  Name:           Linux 2.6.37.6-0.7-default i686
  Version:        2.6

Well my dear i allmost go crazy - sure thing:


I run a linux-root-server that is administered by a friend of mine. i controll the SFTP session - with filezilla (see all i mentione above a buddy told me: It's not actually filezilla, it's the umask that sftp uses.

he advice me to Change


Subsystem sftp /usr/libexec/openssh/sftp-server

to Subsystem sftp /bin/sh -c 'umask 0002; /usr/libexec/openssh/sftp-server'


in the server's sshd_config file, and restart sshd, and you should then find that sgid bit is preserved if the parent directory has it set.


well what do you think - can it be the stuff / and the things, that the buddy told me. -do you also think that the fault is rootet in the server-config?.

well i guess so - i am pretty sure

Reply with quote

Advertisement

You can post new topics in this forum