Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Hi thanks for the help but I solved it by installing apache in ubuntu console. This created a www folder and things inside this folder worked with generate URL function. I dont understand why it works but hey it works. :)


Re: I generate HTTP link, but the link doesnt work?

I guess you didn't configure the mapping correctly.

We cannot help you with that. We do not know your web server.

But I'd guess that the /root/domains should not be in the URL. So I believe the "Web root path" should be /root/domains. But maybe some other settings are needed, like "URL root path". If it is virtual web host, you definitely need to use a specific host name, not just IP address.


I generate HTTP link, but the link doesnt work?


So I connect to my server, I upload a file. I then right click this file to generate a HTTP link so the public can download. But I just get "This site can’t be reached" when I try to put it in my browser. What could be the cause?

Heres the link:

Heres the long link when I hold ctrl + shift:
powershell.exe -ExecutionPolicy Bypass -STA -NoProfile -File "C:\Program Files (x86)\WinSCP\Extensions\GenerateHttpUrl.WinSCPextension.ps1" -webRoot "" -rootPath "" -hostName "" -serverName "" -path "/root/domains/" -pause -clipboard