Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: symbolic directory links

Yes, the "Edit raw settings" is only in the recent versions. And indeed the "Resolve symbolic links" option has no effect here.
bittersmile

Re: symbolic directory links

Thank you very much. Never realized this difference!
I always use "backspace" key to "go back". So it seems the backspace is for "go up". I tried Alt+Left and it worked correctly to "go back".
I am still using 5.9 version. There is a "resolve the symlink" option in the "advanced", but it seems make no difference enable it or not (clear the cache done). Did not find the raw setting option. Maybe only available for later version?
martin

Re: symbolic directory links

If you go "back" (as in Go to > Back) you should end in /pathA. You probably go "up" instead, right? Because after you enter /pathA/link, you end up in /pathB/source, so "up" in indeed /pathB.

So go really "back", not "up".

Actually WinSCP 5.18 beta has a (hidden) option that should prevent resolving the symlink. So when entering link, you should end up in /pathA/link, not in /pathB/source.

On the Login dialog, go to Advanced > Edit raw settings (https://winscp.net/eng/docs/ui_login_raw)and add:
SFTPRealPath=1

You will also need to clear the cache. Once you login, go to Commander > Clear Caches.
bittersmile

symbolic directory links

Hi,
I have a symbolic directory link /pathA/link pointing to /pathB/source. In winscp interface everytime when I enter the link (through /pathA) and go back, it put me under /pathB. Is there an option I can change it so when I go back I am back to /pathA?
Thank you very much.