Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Do you have any reference that shows that for Chinese regions one has to explicitly include the region name in the endpoint hostname? I find it bit strange.

Can you setup a test bucket in a Chinese region for us to test?

Yes, no. business license in China Cannot create account. use “” as Hostname also failed to connect. Actually use “ -” or “” as a host name is no problem, but many ordinary users in China do not know to modify this, it will not be able to use Winscp, can only switch to other software

It seems that I cannot test is, as apparently you cannot create bucket in China without special AWS China account. Which you cannot create, unless you have business license in China. Is that correct?

Anyway, would it work, if you use as Host name? (instead of the default

Attached are two configurations to log in to S3 logs. It is suspected that due to the restrictions in China, the host name directly using Amazon S3 cannot be automatically transferred to China. So is it not possible to file protocol in China S3 single file or in the advanced site settings in the regional settings to choose China area, automatically change the host name to the correct?

Re: Amazon S3 does not automatically bring out area URL

Are China regions somehow special? Afaik, for other regions, you do not need to change the hostname to be able to connect.

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Amazon S3 does not automatically bring out area URL

I'm using Amazon S3's China account, and when I select "Amazon S3" at "File protocol," Then in the "advanced site settings" in the selection of regional "cn-northwest-1" in fact, "host name" Department did not change, save the connection site is not connected. And I in the "host name" at the manual input site address "", regardless of "advanced site settings" in whether to make a choice, can connect. Looks like the S3 default region in Advanced Site Settings doesn't work。
I put the relevant pictures in the attachment.
English level is poor, please forgive me