Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Yes, I can confirm that!

Ok, so I did some tests. It seems that I do not even have to drag/transfer any files. Merely opening the drive in the local panel locks the drive forever. Even if I then open another drive. Can you confirm that?

Yes i did drag a file from remote to local using SFTP.

So you did download a file to the external drive, right?
How exactly did you download it? Did you drag the file from remote to local panel? Or otherwise? What protocol did you use?

For the most time I have WinSCP running all the time.

What I did was:
I inserted my external drive and opened a new connection and copied some files to the external drive. I then closed the connection by closing the tab and I then tried to safely remove the drive, but it was in used by WinSCP. It wasn't any large files I was coping and it is a fast SSD running over USB-C.

I'm NOT using the portable version.

Re: Forced to quit WinSCP to safely remove external drives

What does lock the drive? Just starting WinSCP? Or do you have to do something specific with WinSCP? Do you have WinSCP installed? Or are you using portable WinSCP?

Forced to quit WinSCP to safely remove external drives

Every time I have used my external SSD with WinSCP I have to quit WinSCP because it has locked the drive. Even if I have closed the tab it seems to keep the lock on the drive. The drive is not open in some of the other tabs I have open.

If I run the program "What's locking this folder?", I can see that it is WinSCP that has locked the drive.

There must be a way to prevent this? If none of the sessions have the drive open it shouldn't keep the drive locked.

WinSCP 5.19.5
Windows 10 x64 version 1909