Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Script using is unable transfer file to destination. Able to transfer with WinSCP client

I am currently transferring some files from a local directory using WinSCP to a remote FTP server. I am able to do this transfer using the WinSCP Client application by drag and drop the files to the destination. I am trying to automate the process using However, when I try to do the transfer from local to destination, I am getting an error
Transfer channel can't be opened. Reason: The requested address is not valid in its context.

I tried to use both synchronize remote and put' commands to do the transfer. Both commands are returning the same error. I even tried to see if I can do a directory listing (ls) of the remote server from the script. This too gave the same error.

Please note that I am able to transfer file from the same local location using the client by drag and drop or by using the Synchronize tool from the client.

Could someone please help to identify the cause for the issue and suggest potential solution?