Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


x-sftpserver and x-shell not working properliy in URLs

Version: WinSCP 5.21.7 on Windows 10.
Following the instruction:
Generate Session URL
Advanced site settings
I have the URL (SFTP) and made a URL-shortcut for easy access to my server, everything works fine. Pretty Good!

Lately, I tried to use a custom shell and sftpserver settings, also make it a url-shortcut, but I found that the x-shell and x-sftpserver in the URL don't work. Example:

Steps are like:

  1. create a new session, fill in the username and pass
  2. change Advance Settings, use custom shell and sftp-server argument.
  3. save session
  4. right click on saved session and generate a URL, copy it.
  5. open system file explorer, paste the URL in the address bar and press enter.
  6. successfully connected through WinSCP. Right click on the session tab, generate the URL again, the URL would be sftp://user:pass@servername/ without any shell or sftp-server argument in it. Yeah, not functioning in session either.