Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


I got this error too today after upgrading to latest version (6.3.2).
This was not an issue before, so I knew it had something to do with WinSCP.
In my case, the problem was fixed by removing an echo from my .bashrc
# .bashrc
# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
# User specific aliases and functions
#echo "loading .bashrc"
export AWS_REGION="us-east-1"

Commenting-out the line with the echo command, fixed the issue in my case.

any update on 6.3 release ? Waiting for a long time.

Re: Timeline for 6.2 release

@EricFHLB: I hope to release WinSCP 6.3 stable within a month.

Timeline for 6.2 release

When is 6.2 going to be released? We are encountering this error message. I would prefer to not use pre-release code but we would consider it if the release is not coming for a month or more.

Re: Received too large SFTP packet

Note that in both cases (@axe and @sbeckles), the server is WS_FTP 8.8. Possibly something has changed in that version of the server that triggers the bug in WinSCP.

Re: I am also getting "Received too large (2048009 B) SFTP packet" error

@sbeckles: I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

I am also getting "Received too large (2048009 B) SFTP packet" error

I have several PowerShell scripts that were using WinSCPnet for years to download files from SFTP sites (SFTP protocol) and they worked well (Windows Server 2016). Then a few weeks ago, I got this error downloading the same 2 files (1GB and 5GB), that I was downloading for years, from one of our SFTP sites:
Received too large (2048009 B) SFTP packet. Max supported packet size is 1024000 B. ()

WinSCP disconnected, reconnected, resumed downloading for a little while and then the same error occurred again and again. A file that was taking 15 minutes to download now took over 10 hours if I was lucky. The first number in the error message changed all the time, for e.g.:
Received too large (2184553 B) SFTP packet. Max supported packet size is 1024000 B.

I tried the same files on the WinSCP GUI (Windows 10) and got the same error. I switched to the SCP protocol and could not authenticate. I tried a number of different suggestions that I saw on the internet and nothing worked. I moved from version WinSCP 5.19.6 to version 6.1 and got this same problem with the GUI and WinSCPnet. I switched computers and networks but WinSCP returned the same error. I then tried FileZilla GUI and this worked every time.

I would like to try WinSCP 6.2 which I saw in this post. I am being asked to used a different solution to download files but I would rather not.

I have attached a sample of the log file.

I used FileZilla, it worked with no problem...

@axe: Ok, but that won't help unfortunately. What about Debug 1 level?

When I changed to debug 2 it worked (downloaded the file). Attached the logs.

Please attach a full log.
Also please enable Debug 2 level logging.

. 2023-08-29 22:53:56.052 Access granted

. 2023-08-29 22:53:56.053 Opening main session channel
. 2023-08-29 22:53:56.179 Opened main channel
. 2023-08-29 22:53:56.310 Started a shell/command
. 2023-08-29 22:53:56.315 Doing startup conversation with host.
> 2023-08-29 22:53:56.317 Type: SSH_FXP_INIT, Size: 5, Number: -1
< 2023-08-29 22:53:56.443 Type: SSH_FXP_VERSION, Size: 5, Number: -1
. 2023-08-29 22:53:56.443 SFTP version 4 negotiated.
. 2023-08-29 22:53:56.443 We will use UTF-8 strings as it is mandatory with SFTP version 4 and newer
. 2023-08-29 22:53:56.443 Changing directory to "/ak47".
. 2023-08-29 22:53:56.443 Getting real path for '/ak47'
> 2023-08-29 22:53:56.443 Type: SSH_FXP_REALPATH, Size: 19, Number: 64528
< 2023-08-29 22:53:56.581 Type: SSH_FXP_NAME, Size: 32, Number: 64528
. 2023-08-29 22:53:56.581 Real path is '/ak47'
. 2023-08-29 22:53:56.581 Trying to open directory "/ak47".
> 2023-08-29 22:53:56.581 Type: SSH_FXP_LSTAT, Size: 23, Number: 64775
< 2023-08-29 22:53:56.715 Type: SSH_FXP_ATTRS, Size: 38, Number: 64775
. 2023-08-29 22:53:56.715 Getting current directory name.
. 2023-08-29 22:53:56.715 Startup conversation with host finished.
. 2023-08-29 22:53:56.725 File: '/ak47/20230820_OptIn.csv' [2023-08-20T22:08:26.000Z] [67100549]
. 2023-08-29 22:53:56.725 Copying "/ak47/20230820_OptIn.csv" to local directory started.
. 2023-08-29 22:53:56.725 Binary transfer mode selected.
. 2023-08-29 22:53:56.726 Opening remote file.
> 2023-08-29 22:53:56.726 Type: SSH_FXP_OPEN, Size: 47, Number: 65027
< 2023-08-29 22:53:56.862 Type: SSH_FXP_HANDLE, Size: 12, Number: 65027
> 2023-08-29 22:53:56.862 Type: SSH_FXP_FSTAT, Size: 16, Number: 65288
< 2023-08-29 22:53:56.994 Type: SSH_FXP_ATTRS, Size: 46, Number: 65288
> 2023-08-29 22:53:56.995 Type: SSH_FXP_READ, Size: 24, Number: 65541
. 2023-08-29 22:53:57.253 Skipped 31 SSH_FXP_READ packets
< 2023-08-29 22:53:57.254 Type: SSH_FXP_DATA, Size: 32777, Number: 65541
. 2023-08-29 22:54:00.975 Attempt to close connection due to fatal exception:
* 2023-08-29 22:54:00.976 Received too large (1049081 B) SFTP packet. Max supported packet size is 1024000 B.
. 2023-08-29 22:54:00.976 Closing connection.
. 2023-08-29 22:54:00.976 Sending special code: 1
. 2023-08-29 22:54:01.806 Fatal error while disposing the SFTP queue.
. 2023-08-29 22:54:01.807 Connection was lost, asking what to do.
. 2023-08-29 22:54:01.807 Asking user:
. 2023-08-29 22:54:01.807 Received too large (1049081 B) SFTP packet. Max supported packet size is 1024000 B. ()
. 2023-08-29 22:54:03.313 Answer: Abort
* 2023-08-29 22:54:03.468 (ESshFatal) Received too large (1049081 B) SFTP packet. Max supported packet size is 1024000 B.
* 2023-08-29 22:54:03.468 Copying files from remote side failed.

Re: Received too large STFP packet

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Received too large SFTP packet

Hello there,

While I am downloading a file from FTP, it pops up this message:
Received too large STFP packet. Max supported size is 1024000 B

But no issues with uploading. Any idea?

Thank you in advance.