Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Wrong host name

Thanks for sharing your solution. I'll document it.

Wrong host name

And there it is: I just needed to remove the bucket name from the 'Host name',so instead of the link shown on the website, e.g.
it should have been

Might be worth leaving here in case someone faces the same silly issue. Or perhaps you can improve WinSCP by making it point this out (or automatically strip?)

Thanks anyway :)

Signature problem with Cloudflare R2

When I attempt to connect to Cloudflare R2 using the S3 protocol, I receive the following error:

Authentication failed.
The request signature we calculated does not match the signature you provided. Check your secret access key and signing method.
Connection failed.
OK Reconnect Help

This is what I can confirm/have tried, to no avail:

  • I have double checked the access key and secret.
  • I tried re-generating a new set of keys.
  • The key is a 'full access' admin key.
  • I have tried changing the region from blank to auto.

Log attached with "debug-2" level, though it doesn't really show much. Does WinSCP use AWS Signature v4? I know that v2 is not supported by the R2 system. On the other hand I have seen other posts being able to connect to that service, so I must be doing something wrong myself?