Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

goog49

niver wrote:

martin wrote:

niver wrote:

With 4.2.7, using the sftp protocol, everything is working, all timestamps are synchronized. When I upgrade to 4.2.9, all timestamps on the server are one hour behind the local timestamps, in both the file list and the Synchronize dialog.

What if you upload new file? Would it have a correct timestamp? Also when talking about timestamps on the server, do you mean timestamp you see in the file panel or actual timestamp (e.g. in console)?


Thanks for the heads up, I was simply assuming 4.2.7 was correct, while it was one hour off. A mere resync of the timestamps in 4.2.9 will likely fix my issue.



I'm using 4.3.3. same problem. Working it for a couple hours now. Can't find a way to enter the timezone offset in any 'login dialog'. That's as close as I got to a solution. The server only uses plain FTP, not SCP or SFTP. The server uses UTC, I'm using EDST.
niver

martin wrote:

niver wrote:

With 4.2.7, using the sftp protocol, everything is working, all timestamps are synchronized. When I upgrade to 4.2.9, all timestamps on the server are one hour behind the local timestamps, in both the file list and the Synchronize dialog.

What if you upload new file? Would it have a correct timestamp? Also when talking about timestamps on the server, do you mean timestamp you see in the file panel or actual timestamp (e.g. in console)?


Thanks for the heads up, I was simply assuming 4.2.7 was correct, while it was one hour off. A mere resync of the timestamps in 4.2.9 will likely fix my issue.
martin

niver wrote:

With 4.2.7, using the sftp protocol, everything is working, all timestamps are synchronized. When I upgrade to 4.2.9, all timestamps on the server are one hour behind the local timestamps, in both the file list and the Synchronize dialog.

What if you upload new file? Would it have a correct timestamp? Also when talking about timestamps on the server, do you mean timestamp you see in the file panel or actual timestamp (e.g. in console)?
niver

Using 4.2.9 on Win7 x64, I get the same problem as 4.2.8.

With 4.2.7, using the sftp protocol, everything is working, all timestamps are synchronized. When I upgrade to 4.2.9, all timestamps on the server are one hour behind the local timestamps, in both the file list and the Synchronize dialog.

The DST setting is set "Adjust remote timestamp to local conventions", but if I set it to "Adjust remote timestamp with DST", the problem becomes even worse, with a 2-hours difference between files that should have the same one.

The remote server is not on the same timezone than I, but this shouldn't make any difference for the SFTP protocol.

Did I do something wrong? Why is 4.2.9 different from 4.2.7 regarding timezones?
pet

Re: Local timestamp one hour ahead in synchronize list

martin wrote:

johnstonj99 wrote:

I am having a the same problem. Where do I download version 4.2.9?

It will be released shortly.



Can you send me the newst version 4.2.9 please
to solve my problem with synchronization of my Win7 PC with a Linux server?
Guest

Re: Local timestamp one hour ahead in synchronize list

martin wrote:

I have sent you an email.


I have the same problem when synchronizig my win 7 pc on my Linux server.
Can you sent me the newest version 4.2.9 too, please?
martin

Re: Local timestamp one hour ahead in synchronize list

johnstonj99 wrote:

I am having a the same problem. Where do I download version 4.2.9?

It will be released shortly.
johnstonj99

Re: Local timestamp one hour ahead in synchronize list

I am having a the same problem. Where do I download version 4.2.9?

Thanks!

gallde wrote:

I see the bug is fixed in 4.2.9. Where can I get that version?

martin wrote:

Thanks for your post. This bug is being tracked already.
ds316

Re: Local timestamp one hour ahead in synchronize list

martin wrote:

I have sent you an email.


Hi Martin, thanks a lot for quick reply, I've emailed you my findings.
martin

Re: Local timestamp one hour ahead in synchronize list

I have sent you an email.
ds316

Re: Local timestamp one hour ahead in synchronize list

Should add to the above:
- SFTP protocol.
- happens both from command line and from GUI.


ds316 wrote:

Hi,

similar problem, assume the same:
- Client 4.2.8 running on W2K3 SP2
- Host is W2K8.
- Time and timezone exactly same both servers.
- Files have same timestamp on client and server, however winscp synchronisation script considers server files to be one hour ahead of the client side.

Is this the same issue, and if so how would I go about getting the 4.2.9 code?
ds316

Re: Local timestamp one hour ahead in synchronize list

Hi,

similar problem, assume the same:
- Client 4.2.8 running on W2K3 SP2
- Host is W2K8.
- Time and timezone exactly same both servers.
- Files have same timestamp on client and server, however winscp synchronisation script considers server files to be one hour ahead of the client side.

Is this the same issue, and if so how would I go about getting the 4.2.9 code?
martin

Re: Local timestamp one hour ahead in synchronize list

I have sent you an email.
gallde

Re: Local timestamp one hour ahead in synchronize list

I see the bug is fixed in 4.2.9. Where can I get that version?

martin wrote:

Thanks for your post. This bug is being tracked already.
martin

Re: Local timestamp one hour ahead in synchronize list

Thanks for your post. This bug is being tracked already.
gallde

Local timestamp one hour ahead in synchronize list

Using: WinSCP V.4.2.8 Build 818 on Windows 7
Logged in via SFTP

Weird behavior: Timestamps are fine on normal listing, and file compare works fine. But when I do a Synchronize preview, the LOCAL files (on my PC) are listed as advanced by one hour, so no longer match the remote. The setting for DST in the session does not make a difference. I have tried to find a solution to this in the forums to no avail. Any help?