Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: A time stamp is displayed -1Hour.

Thanks for your feedback.
heiji

Re: A time stamp is displayed -1Hour.

The version 5.1.4 of WinSCP fixes my problem.
Thanks.
:wink:
heiji

Re: A time stamp is displayed -1Hour.

Thanks for contacting me.

The development build of WinSCP fixes my problem.
Thanks. :D

However, the warning of the attached file is displayed.
I expect that it will be early exhibited by the newest Japanese version of WinSCP. :wink:
heiji

Re: A time stamp is displayed -1Hour.

Thank you for the proposal.
I am waiting to be send a debug version of WinSCP.
Thanks.

p/s
Sorry, I wrote the mistaken English in E-mail.
martin

Re: A time stamp is displayed -1Hour.

Thanks. Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
heiji

Re: A time stamp is displayed -1Hour.

martin wrote:

It does not look like a Debug 1-level log. Pleasse try again.


I'm sorry.
It seems that the file in which I was mistaken was attached.
It attaches again.
Is this indifferent from a Debug 1-level log?
I am sorry very much.
I apologize in piles.

I need your help well succeedingly.
Thanks.
heiji

Re: A time stamp is displayed -1Hour.

martin wrote:

It does not look like a Debug 1-level log. Pleasse try again.


I set up the level of the log file like an attached image.

But you said "It does not look like a Debug 1-level log".
How should I do?

Thanks.
heiji

Re: A time stamp is displayed -1Hour.

martin wrote:

It does not look like a Debug 1-level log. Pleasse try again.


I select "Debug 1-level log" of configuration. But WinSCP 5.1.3 don't output "Debug 1-level log" on Windows7 Ultimate OS. I tryed it again and again.

I try it on another PC of WindowsXP Professional OS, WinSCP 5.1.3 output "Debug 1-level log".

Is it a BUG of WinSCP 5.1.3? Please check it.

Thanks.
martin

Re: A time stamp is displayed -1Hour.

It does not look like a Debug 1-level log. Pleasse try again.
heiji

Re: A time stamp is displayed -1Hour.

martin

Re: A time stamp is displayed -1Hour.

Retry: I need Debug 1-level log file from 5.1.3.
heiji

Re: A time stamp is displayed -1Hour.

Thanks for your comment.

The screen capture of GUI is attached.
Although the same directory is displayed by WinSCP ver.5.1.3 and ver.4.3.7, time stamps differ for 1 hour.
I think that ver.4.3.7 is right.
This screen capture is the same as the directory displayed by Debug 1-level log file attached last time.

Thank you for your consideration.
martin

Re: A time stamp is displayed -1Hour.

Thanks. Though I need Debug 1-level log file. Log from 5.1.3 is enough for now. Thanks.
Also can you pick one file and specify what timestamp you see in the GUI and what timestamp you expect and why?
heiji

Re: A time stamp is displayed -1Hour.

I submited the log with this post as an attachment.
"OOO" is the removed data.

Thank you.
martin

Re: A time stamp is displayed -1Hour.

It seems you haven't attached the logs.
heiji

Re: A time stamp is displayed -1Hour.

Thank you for your comment.

5.1.3.log
Time zone: Current: GMT+9, Standard: GMT+9, DST: GMT+10, DST Start: 1899/12/30, DST End: 1899/12/30
Transfer Protocol: FTP DST mode: 1
4.3.7.log
Transfer Protocol: FTP DST mode: 1
* Time zone and DST information is not written.


Because "DST Start" and "DST End" are equal, "DST: GMT+10" should be ignored.
But "DST: GMT+10" minus "GMT+9" is effective, I think.

The difference in others of 5.1.3.log and B 4.3.7.log.
4.3.7.log is used "LIST -a".
5.1.3.log is used "MLSD". "modify=" is correct. It is displayed as the place +8Hour" which should be displayed as "+9Hour".

Thank you for your consideration.
martin

Re: A time stamp is displayed -1Hour.

Please attach a full Debug 1-level log file showing the problem (using both the latest version of WinSCP and 4.3.7).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
heiji

A time stamp is displayed -1Hour.

Hello.
I live in Japan(UTC+09:00 Not DST).

WinSCP
 Version 4.3.7 : A time stamp is displayed correctly.
 Version 5.1.3 : A time stamp is displayed early for 1 hour.

Client : Windows7 Ultimate 64bit.
Server :Linux l

Thank you for your consideration.

P/S
Sorry, I speak English a little.