Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


I e-mailed you the log. Thank you!

Re: FTPS via SOCKS5 proxy fails to upload file.

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

FTPS via SOCKS5 proxy fails to upload file.

This did not work in any version I tried including the latest 5.5.3. I try to use FTPS to upload file to Oracle file transfer server. This always fails when I am behind a proxy; in logs I see timeout. I tried to upload file now, when I am connected to Internet directly, and it works (at least, WinSCP reports success - remote directory listing is disabled on server).

It almost looks like FTPS data transfer channel ignores proxy.

I have log both for failed (behind proxy) and successful (direct connection) sessions; please let me know how to make it available.