Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


SFTP protocol violation: Invalid response message type (0)


I have a problem with making new folder, or copy folder in SFTP connection. I've clean all data, sessions, reinstall winscp but problem still occurs. I've tried filezilla and there it is no problem. Connection to server going normally, but after trying to make a new folder anywhere, or copy folder this is the error:
SFTP protocol violation: "Invalid response message type (0). Error creating folder 'folder' "

Copy files and deleting or updating goes normally.

WinSCP 5.7 I'm using long time but today after make som changes in session info there is this error. As I mentioned I've tried to clean all and connect but still nothing.

I login in saved session. After that I press F7 key and try to make new directory. After that winscp show me error message.
I'm using GUI – Commander, Windows 8.1 64 bit, WinSCP 5.7 last build and log file is attached.