Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks for sharing your solution.

I finally resolved this .. I feel very embarrassed about my findings but here goes

I decided to look at where the machines actual usernames folders where stored in each of my other machines, but noticed on the machine I am locked out of I only have “users and finally user” in short I have no user name ( that I created ) folder on that machine therefore I decided to login with user and then the password .. that got me in without any access errors.

I have never had this issue before – somehow my created user account name has disappeared and has been replaced by the account name of “user” yet my windows login has what I recognise as my account name. I do not know if this is going to cause me any problems going forward, I probably need some PC networking or other advice.

Thanks for setting the logs to private - although the jpg's should all be visible/downloadable

I have tried the latest version of Bitvise both Client & Server

OpenSSH 3.8.1 for windows ... can't seem to find the correct version for Win 7 that will work.

Cygwin ... looked at a few videos on youtube but never managed to get the correct commands into terminal to allow file access.

I think Cygwin might be my best option .. Or since I am at a lost to sort this I will ask do you have any suggestions for a SFTP/SSH server that might work ??

I have looked at my permissions and as far as I can see everything is set up to allow access across files I am sharing

Re: WinSCP Permission denied error code 3 with FreeSSHd server

Well, all that the logs show is that the server rejects access to the files/folders. I'm sorry, but there's nothing I can investigate there.
You should try a different SFTP/SSH server anyway. The FreeSSHD is abandoned project, not maintained for years.

(I have set all the logs to private).

Still struggling with this -- I have just posted a jpg below FreeSSHd service.jpg of the FreeSSHd server set to manual in services tab. along with the application ticked and running .. is this configuration correct ? I think I am clutching at straws now.

Re: WinSCP Permission denied error code 3 with FreeSSHd server

If you want me to install WinSCP 5.7.6 on the problem machine M1 and send you the log file from inside M1 I will do so - that might be the better bet please let me know.

Hi Prikryl

I decided to install WinSCP 5.7.6 on M1 ( the problem machine ) and then tried to login within the machine environment to see if I could trf files and folders within M1, i.e loop login

I have again posted the log files privately ( well I selected private ) M1-xxxxx-loop-121-(1) and M1-xxxxx-loop-121 just in case but I have looked at them before posting
I have also attached 2 jpgs with error messages FYI

Thank you for looking at this hopefully I will get some assistance here that will help resolve this mystery.

Additional comment added @ 15.36 (16/3/2015) .. I made sure that I checked the .log files as private and the jpgs as public then previewed before sending - yet the private .log files are downloadable ? not sure what happened it could be a website fault - I have checked them in any case and it looks like nothing sensitive has been posted

Re: WinSCP Permission denied error code 3 with FreeSSHd server

martin wrote:

If you do not want to post the log publicly, you can mark the attachment as private.[/size]

Hi Prikryl

I am so glad you have got involved with this - I have produced a private .txt log file ( just in case I missed something ) I have replaced my windows login user names with xxx's and the internal IP addresses with xxx's but left the port number 22 visible.

So I Installed WinSCP 5.7.6 on M2

I Logged into M1 Server ( problem machine ) from M2 .. I noticed that this version of WinSCP 5.7.6 gives you no option to use stored keys ( if it does I could not find it ) .. I imported only 1 stored setting from the old WinSCP & Putty settings ... The user name and password was greyed out so I assume that WinSCP took the stored windows credentials.

I then tried to copy a file from M2 to M1 and the very same error message has appeared which I have also published but left this public, called Server M2 to M1 the log file is called M2-to-M1

Not that I pretend to know what I am looking at but I noticed in the log file this entry CYGWIN_SYSLOG.TXT ?? but I can not see that file or txt when I search for it .. could it be a hang over from my previous Cygwin install that is causing this error ? I may be talking rubbish here so pleaser dismiss it out of hand if you feel the need.

The only other thing I thought of is that there might be the remnants of an old user account on this machine that might have stored some old password ? again it might be the wrong path I am going down.

If you want me to install WinSCP 5.7.6 on the problem machine M1 and send you the log file from inside M1 I will do so - that might be the better bet please let me know


Re: WinSCP Permission denied error code 3 with FreeSSHd server

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

WinSCP Permission denied error code 3 with FreeSSHd server

Hello ALL

I have 4 machines on my network, 3 x win7 ( two pro ) 1 x Home premium and 1 x WinXP SP3 + I apple mac, I can and have always been able to transfer files using the client WinSCP around my network – but for some strange reason I cannot now transfer files to one of the win7 pro machines, I can putty to all the machines without any problems and also VNC to all of them but one machine stubbornly gives me a Permission denied error code 3.

What I have tried is

1) The Latest WinSCP version

2) I was and always used WinSCP v3.3.0 & v3.7.6 but I recently noticed quite a few posts that pointed to a bug with the earlier version (jpg win3.3.0) therefore I tried the latest WinSCP which did not resolve the Permission denied issue, so I stuck with WinSCP 3.5.5 as quite a few posts and then reply s from the Site Admin prikryl who indicated that this version resolved the error problem way back then.

3) I have tried other clients i.e such as Bitvise but still when trying to trf files to the win7 machine I get Permission denied error code 3.

4) FreeSSHd 1.3.1 jpg I am using NT Authentication and have set public key to allowed with Shell, SFTP, and Tunnel all selected.– the key was generated from the putty key generator.

5) The only programme that works as a server on the problematic win7 machine is FreeSSHd 1.3.1, I have tried other programmes i.e Open sshd, I have also tried installing Cygwin spending weeks trying to get this to work but failed, so I am stuck now and I do now need some help.

Can somebody help to point me to getting this Permission denied issue away from my win7 machine –

WinSCP Locally I CAN go destination to source copy / delete or move, - but I can NOT go source to destination ans that route give me Permission denied error code 3 ( in short the right hand column is off limits.

I have been trying to resolve this spending many hours every day for the last 3 months reading posts and trying various things but I just cannot resolve this so I am afraid I need to ask for help – I am not a computer luddite as I have set up my own network and it works well but as I am now asking for help if anybody can assist could you please guide me through any possible solution it will help save time

I have Bitvise server and clients on the other win7 machines without any issue ? if I can add anything else that would be helpful just ask.

Ps Note to prikryl - if I have posted in the wrong section apologies and could you please move it to the section that I may get help.