Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Sorry, I didn't notice that you are using an FTP protocol.

As documented:

With FTP protocol, setting permissions during upload is not supported. You can change permissions explicitly after upload.

Here it is.
i uploaded directory IMPORT to remote directory 2015

Re: setting file permissions while upload - FTP

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

setting file permissions while upload - FTP

WinSCP v.5.7.5 (Build 5665)
FTP protocol
Windows 7 64bit
When upload files, permissions are set incorrectly.
Permissions to files are set to 644 instead of assigned from Options - Transfer settings