Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


It says "knock", not "use".

"UTF-8 Encoding for Filenames" option is here:

The option you are showing is for the internal editor.
So where do you get the problem with UTF-8? In the file names (what this topic is about) or in the internal editor?

Sorry, i'm running late, but it's very busy in here...

I use SFTP and UTF-8.
But to give you some more information i've attached some files.

Re: Problem with SFTP and UTF8 encoding

There's no "SFTP, if rejected, use FTP" mode. So what protocol do you use, SFTP or FTP?
What value do you use for UTF-8 encoding for filenames?

Re: Problem with SFTP and UTF8 encoding

Hello Martin!

I'm using WinSCP 5.5.0,

SFTP, if rejected, use FTP;
Language: German;
Default Encoding: UTF-8;

I've allready read the other options, but I didn't find any further Settings.

Thanks for your help.

Re: Problem with SFTP and UTF8 encoding

You have to give us a way more information.

What protocol? What UTF-8 setting do you use? Did you try the other options?
Did you read ?

Problem with SFTP and UTF8 encoding

Hello @all!

I'm new in here and I saw this topic during my attempt to solve the same Problem which is described in here.
I would be glad if someone could help me by giving me a solution.

Thank's a lot.

Greets DonD

Re: Problem with SFTP and UTF8 encoding

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Problem with SFTP and UTF8 encoding


Support for utf8-encoding when using SFTP does not work. Although I set utf8-encoding for file names in the environment to yes, file names and directories are displayed wrong. German umlaute (ä, ö, ü) are displayed in their isolatin representation of the ut8 encoded string.
Example: Büro instead of Büro

This does not seem to be a server problem. All other clients I tried (and I tried them all... FileZilla, CoreFTP, SmartFTP, WS_FTP, ...) display these names correctly.