Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review



Please don't waste any more time on this. I have found out, through another issue, that someone changed the SSH port to 223 with the use of a fat finger. Very sorry to take up your time. Never thought to check the obvious.

Re: Log

Well, actually, you wrote that you cannot login with PuTTY either. So it was not necessary to test SCP. It cannot work, if PuTTY does not.


Thanks - here is the log file as requested

Re: Update

Can you post a complete session log file for the "Error skipping startup message" error?

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.


Second SFTP attempt had no errors and still only data folders. No sure why it can find the files now...

Now tried SFTP

I switched on SFTP and tried access. Error was:

Error changing directory to

No such file or directory (I think it is directory VPNCentre but could be wrong, and don't know what file it is looking for)
Error code: 2
Error message from server: No such file

But on selecting OK, I got in! But not the hidden file structure, just my data folders.

Hope this helps


The reason I am doing this is that the VPN suddenly fell over after months of being fine. It now seems that I had the ifconfig-push line wrong in a file. this has now been fixed by Synology as I still can't get on the box and the VPN is now working - hurray! I have asked them to look at the file for my logon in case I have got the same line wrong. I am not sure whether they have done it yet (they are rather slow) but in trying to log on I just got:

Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

Although this is no longer happening!

My config for the shell is: Shell = default, Return code var = Autodetect, Listing command = ls -la
Is this helping?

Martin, thanks for responding. I have been on my own on this one for ages! The NAS does not allow SFTP currently but I could get this changed if needed. I can not log in with PuTTY either; similar issue with access being denied. Should my account work on the GUI and WinSCP?

Re: Account not letting me in

Did you try using SFTP? Can you login with PuTTY?

Account not letting me in

I don't understand it - I can log in on the Synology GUI but not on the WinSCP using same username and pwd. It must be simple but then so am I! Pointers much appreciated as I have been banging away for too long.

I am using 5.9.2 (build 6958) on win 7 PC connecting to Synology NAS DS214 using SCP over port 22. I did notice this after an upgrade on the NAS but I think it is because I have fogotten what to do since I have not logged on for ages.


PS Log attached