Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Permission Denied (Error code 3) when downloading a file

This probably has nothing to do with WinSCP.

It's the server that denies you the access, not WinSCP. We cannot know why the server is doing that.

Anyway, can you attach a full session log file showing the problem (using the latest version of WinSCP)?

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Permission Denied (Error code 3) when downloading a file

One of my team members(from overseas) up-loading a ZIP file via Media Shuttle(provided by SIGNIANT).
Now, when I and other members tried to download the ZIP file, we all get following error message:

Permission denied.
Error code: 3
Error message from server: Permission denied

So, I highlighted the zip file and right click on Properties, then, change the permission setting click on the all the R, W, X boxes.
When I did this, the Octal changed from 0000 to 0777. But, still get the same error code shown above.

It is funny that there are other files(zip or other formats) that have been up-loaded either via WINSCP or Media Shuttle and we do not have problem to download those files....

I can see the "root" does not have "Right". It indicates ---------- . I went up the holder tree and tried to change the permission levels of the root holders, but I was not able to do it.

Any idea how to resolve this? I am new to WINSCP and I am hitting wall here...