Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


"Disabling temporary file name during transfert"


I will try this option and hope will solve the following error message I get.

winscp> put ARTMAS_24399482_1.txt
ARTMAS_24399482_1.txt | 463 KiB | 2673,2 KiB/s | binary | 100%
Cannot close remote file 'ARTMAS_24399482_1.txt'.
General failure (server should provide error description).
Error code: 4
Error message from server: EBIBrokerSshFile.NullDocument
(A)bort, (R)etry, (S)kip, Ski(p) all: Skip

Disabling temporary file name during transfert


I put file on a SFTP server successfully with the user interface.
But, I run it as a script, the files are first copied with a temporary extension on the SFTP server, and then I suppose WINSCP will rename them.

The point is that I won't be allowed to rename file on the server.
How can I disable the temporary file name transfert mode in a batch mode ?

I read the manual, FAQ and search in the forum.

Is there anyoption for that ?