Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


@Guest: The error can happen with many commands. So it's not as easy as putting link to the get documentation. Anyway, I've added it.

I was getting an error:
Checking existence of file.
Checking existence of partially transferred file.
(ETerminal) No such file or directory.
Error code: 2
Error message from server: <filename>.filepart does not exist

So I searched for
"winscp Checking existence of partially transferred file"

and this page:
describes the functionality, and says:
To configure transfer to temporary file name in scripting, use -resumesupport switch of file transfer commands. In .NET assembly use TransferOptions.ResumeSupport.

But does not give specifics on how to use, or a link. I would suggest adding something more specific about put command and a link to this page:

Re: THanks!

@hampy (and others): What documentation do you want us to update? Where did you look for this information? Can you post a link to the page, where you expected this information? It's documented on many places.


This was WAY harder to find than it should have been. Thanks!! Someone update the doco please!

Thank you!!

@joesyuh: Thank you! This helped me. I have been going in circles looking at comments about ini files to no avail. This was the answer I was looking for!

Ignore me. I had such a hard time finding this the last time I looked. Maybe this will help someone else...

The code is:
put "C:\xxxxx\*.csv" /xxxxx/*.csv -resumesupport=off

Disable Resume Support

I am trying to disable the Resume settings for a scripted file transfer. I have followed the tutorials and read the documentation and it is still not working as expected.

Here is my open string:
open s -rawsettings ResumeSupport=1 ResumeThreshold=10240000 -hostkey="xxxxx"

I have also tried this:
open s -rawsettings ResumeSupport=2 -hostkey="xxxxx"

The issue is that the SFTP site I am uploading to does not allow me to rename files. So winscp is uploading the file with the extension .filepart and then it will not rename it at the end. How can I disable resume support.