Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Will this be implemented?

renebaudisch wrote:

We like WinSCP and without this feature we will have to switch to another product.

Please vote for the feature in the tracker, if you want to get it implemented.

Will this be implemented?

We like WinSCP and without this feature we will have to switch to another product.

Hello Martin,

Thank you very much for the update and will look forward to the updated release. I've found an alternate product in the interim.

Re: S3 Upload Issue

I understood what you mean. I might not have explained myself properly either. WinSCP currently uploads all files as private. And there's no way to configure another access level.

This issue has been added to the tracker:

Re: S3 Upload Issue

Hello martin,

Thanks for responding so quickly, unfortunately I might not have explained myself properly.
I am not trying to manage files on an S3 server, I'm simply trying to upload files to an S3 server using WinSCP, and make those files "public" for anyone to download them via a URL.
WinSCP uploads the files without problem, but I am told that my client (WinSCP) configuration might be set incorrectly for new files since the permissions appear to be set as "private" on the server, even though my WinSCP Permissions is configured as per this screen cap

I tried both 0640 & 0775 as options, any file I try to download gives me this error "This XML file does not appear to have any style information associated with it. The document tree is shown below." etc..

martin wrote:

WinSCP cannot manage access for files on an S3 server.

You have to use S3 console on

S3 Upload Issue

My apologies if this is a pretty basic question, but I tried finding a solution by searching the forum to no avail.

A website I use recently migrated to an S3 server, the video files I upload complete without any errors, but any link generated for downloading results in "access denied".

I am told by the site admin that my files need to have the permissions changed to public, since the default is private.
I'm using the latest version 5.13.1 (Build 8265) and my transfer setting is default,with the transfer mode set to Automatic, and upload options using "Set Permissions" configured for "Octal 0644".

I am told that the above should work, unfortunately it does not, any configuration suggestions would be appreciated. Thanks