Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Weird Bug?

@rds: Can you reproduce the problem? What editor are you using?

Weird Bug?

Old topic but I just wanted to throw this out there.

I received the "cannot find file specified" error when I double clicked a text file to open it in my local editor, made my edits, then saved the file.

The error message said the file should be located in:

But when I manually checked the Temp file, the only "scp" folder listed there was scp24398.
Somehow the folder that was created was different than the folder it was looking for.
When I manually created the scp243983 folder, the error went away.

It worked

Then you must have fixed it by doing something else, because whenever i switch back to a .13 version, the problem comes back, but doesn't happen when i use the version you gave me. will try the RC and see how it goes. thanks.

Re: Version Clarification

@apatt: 5.14 is available for download:
Though I do not think, I've changed anything in the version I've sent you.

Version Clarification

Sorry, I got the versions wrong.. What you gave me reports as 5.14 and it looks like you current version on the website is 5.13.x, so when might you expect 5.14 to come out or be able to migrate your change in 5.14 back into 5.13.x?

It worked

Sorry it took so long to get back to you. The new version worked. I'm not seeing the problem any more. But it looks like you have not merged this into the 14.x version which would be great, or when are you planning on releasing the 15.x version (which the dev version reports as)

Re: The system cannot find the path specified

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

The system cannot find the path specified

Only part of the path exists..

When I got this error, it was looking for

The I hit abort and I get another error (attached)

I saw ok to that message, try to edit the file again, and then it was able to edit with a path of

without any trouble.

This doesn't happen every time, just from time to time. Not sure when the problem started, but it's really annoying. I've been using WinSCP for years and love it. This has started in maybe the last 6 months or so.. I update from time to time, not always having the latest, but staying reasonably up to date.

Re: The system cannot find the path specified

With having the error message still showing, can you check if the path in the error message exists? In this case it would be C:\Users\apatt\AppData\Local\Temp\scp11306\opt\apatt_aps (the path will differ the next time you try). If it does not exist, please find, what part of the path does exist. If it exists, try creating the file (aps.apache.conf) in the folder.

The system cannot find the path specified

winscp version: 5.13.2 (Build 8455)
windows version: 10 Pro
protocol : SCP
Using GUI Explorer
System Error. Code 3.
The system cannot find the path specified

(screenshot attached)
I right clicked on the file (aps.apache.conf) and selected Edit. To resolve the issue, I refresh the directory. I'm not sure exactly when it started, but doing a fresh install, deleting all of the config made the problem go away for a little while and then it came back. I do have an external editor selected (UltraEdit). This use to work with no problem, but in the last few months has been a problem more and more frequently.