Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Cannot copy .cfg file. Permission Denied

Please attach a full session log file showing the problem (using the latest version of WinSCP).

Are you able to overwrite the file using any other SFTP client?

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Cannot copy .cfg file. Permission Denied


I am trying to copy a config file into emulation station on an Odroid XU4 using Winscp.
My problem started after booting an image (Wolfanoz) from my micro sd card onto my Odroid XU4, It says that the configuration file is missing or invalid.
After checking, I seems that the config file 'es_systems.cfg' contains no data...

So I have a copy config of the file that I need, so I attempted to SSH from my laptop to my Odroid XU4 (similar to Raspberry Pi), across to the Micro SD card containing the boot image, but I am getting the following message:

Cannot overwrite remote file

General failure (server should provide error description).
Error code: 4
Error message from server: Failure

Common reasons for the Error code 4 are:
- Renaming a file to a name of already existing file.
- Creating a directory that already exists.
- Moving a remote file to a different filesystem (HDD).
- Uploading a file to a full filesystem (HDD).
- Exceeding a user disk quota.

I have tried to CHMOD permissions to 777 and tried to change properties manually to 777 (right click file and change permissions) - to no avail..

I am lost, can somebody please help me?

Thanks in advance