Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

makaplan

No significant improvement on SFTP or SCP in my case

Hi guys

I have tried both SFTP and SCP with connection buffer size optimization disabled, and it doesn't improve my slow (about 30x slower than the network) transfer speeds. Are there other common causes for slow transfer speeds that I should consider?

Thanks!
martin

linuxdave wrote:

Yes. 100% of my usage is SCP protocol only.

Can you test it with SFTP?
linuxdave

martin wrote:

Are you really always using the SCP protocol only?

Yes. 100% of my usage is SCP protocol only.
martin

linuxdave wrote:

Over the last few years I've used WinSCP on multiple different computers and different networks and disabling this option ALWAYS improves my SCP transfer speeds by more than a factor of 10. Today I went from 2KB/s to 60MB/s.

Are you really always using the SCP protocol only?
linuxdave

Fresh install of Windows 10 + Latest winSCP today (v5.17.7 Build 10640) and I see this problem still an issue years later, in 2020!

Over the last few years I've used WinSCP on multiple different computers and different networks and disabling this option ALWAYS improves my SCP transfer speeds by more than a factor of 10. Today I went from 2KB/s to 60MB/s.

Add my name to the list of people who really think this option needs to be disabled by default. In all of my installs, I've yet to see a single instance where this option improved speeds.

Thank you for your work on WinSCP. Other than this annoyance, it has been a great tool that I've used for years.
seb

I know this is an old thread, but the above changes did not help me in my case. What I found was the ordering of the ciphers played an important part in speed for SFTP from the vendor we were connecting to. At most I could get was 5.5Mb~ but after the below changes we were up near the 25.5Mb~ range. I would suggest adding a mention to ordering the supported ciphers to the FAQ.
Raw settings for my session options were changed from
.AddRawSettings("Cipher", "3des,blowfish,aes,chacha20,WARN,arcfour,des")

to
.AddRawSettings("Cipher", "blowfish,aes,3des,chacha20,WARN,arcfour,des")


Came across this article that helped explain the impact of the ciphers used on SFTP speeds which helped us to improve the transfer speed.
https://www.systutorials.com/improving-sshscp-performance-by-choosing-ciphers/
martin

Re: WinSCP slow speed SCP/SFTP - How I fixed it

panreyes wrote:

I would recommend disabling this option by default and showing an alert whenever the user is trying to connect with this option enabled (and a checkbox to disable that alert in the future).

I'm pretty sure the option speeds up the transfers for most (that's why it is on by default). It's probably only on some rare network setups, or possibly buggy network drivers, where disabling the option helps.
panreyes

Re: WinSCP slow speed SCP/SFTP - How I fixed it

Hi!

This fix also helped me a lot! I was downloading at ~500KB/s, now I'm downloading at full speed: 44MB/s.

I would recommend disabling this option by default and showing an alert whenever the user is trying to connect with this option enabled (and a checkbox to disable that alert in the future).

I'll repeat: from ~500kbps to 45,3MB/s (It grew while I was writing this!)
jmail@...

WinSCP Slow

My WinSCP on a Raspberry Pi3 got from kb to MB with:
/boot/cmdline:
ipv6.enable=1 dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=4deb7a84-02 rootfstype=ext4 elevator=cfq fsck.repair=yes rootwait

/boot/config.txt:
<knip>

# uncomment to overclock the arm. 1200 MHz is the default.
arm_freq=1100
arm_freq_min=800
core_freq=400
sdram_freq=400
over_voltage=0
temp_limit=70

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=off
dtparam=i2s=off
dtparam=spi=off

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

#Bluetooth off
dtoverlay=pi3-disable-bt

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=off
start_x=0
gpu_mem=16
enable_uart=0
max_usb_current=1

Also look at: <invalid hyperlink removed by admin>

The big differents was at the cmdline.
Test first with:
hdparm -Tt /dev/sd(x)
Guest-Dana

Re: WinSCP slow speed SCP/SFTP - How I fixed it

Holy cow!!! Thanks for sharing this!
I tried so may things to speed up this download, but it was taking forever. At hour 4 I decided to dig harder and ran across your post here. After unchecking "Optimize connection buffer size", and restarting my download... 5 MINUTES! I burned 4 hours when it should have taken 5 minutes. I can't thank you enough for this tip.
-Dana
martin

Re: Used protocol etc.

Louis2 wrote:

I am using SFTP and the very latest WinSCP version
Sincerely,

Thanks. Can you start a new thread and post a log file?
Louis2

Used protocol etc.

Hello,

I am using SFTP and the very latest WinSCP version
Sincerely,

Louis
martin

Re: WinSCP does not use CPU effective ==> slow

louis2 wrote:

When transfering a big systembackup file towards the NAS I noticed that the transfer rate was only about 640 gbit. I did at expect something like three to four times that.

So I looked at the cpu load of the nas (moderate intel Pentium g5460, 16GB) which was about 14% ….. and did have a look at the much more powerfull cpu here on my pc (AMD2700X 32GB). And up to my surprise my PC seems to be the limmiting factor ……

Thanks for your report.
What protocol are you using? What version of WinSCP?
louis2

WinSCP does not use CPU effective ==> slow

Hello,

I have a relatively fast freenas server connected via 10G with my PC.

When transfering a big systembackup file towards the NAS I noticed that the transfer rate was only about 640 gbit. I did at expect something like three to four times that.

So I looked at the cpu load of the nas (moderate intel Pentium g5460, 16GB) which was about 14% ….. and did have a look at the much more powerfull cpu here on my pc (AMD2700X 32GB). And up to my surprise my PC seems to be the limmiting factor ……

The taskmanager showed me that one of the possible 16 threads was at 100% all the time. No doubt that that was related to winscp …..

So there seems to be "some" room for improvement:
- starting with migratio to 64 bit
- and using multiple threads

I understand that you are using standard librarys …… but never the less I hope that you can improve things. By the way I did turn of the buffersize optimalisation, that was a slight improvement

Sincerely,

Louis
martin

Re: setting for latest version?

the corey's wrote:

the issue when I do it is that option is greyed out, how do I get passed that part?

The option is mostly relevant for SFTP and SCP protocols only. What protocol are you using?
the corey's

Re: setting for latest version?

martin wrote:

gsds2006@... wrote:

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?

I've posted a link at least twice above already.
https://winscp.net/eng/docs/ui_login_connection


the issue when I do it is that option is greyed out, how do I get passed that part?
martin

Re: setting for latest version?

gsds2006@... wrote:

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?

I've posted a link at least twice above already.
https://winscp.net/eng/docs/ui_login_connection
gsds2006@...

setting for latest version?

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?
nooneofconsequence

worked for me

I was getting about 10 KB/s with it enabled. Disabling it gets me to about 50 MB/s.
One difference I noted is that the CPU utilization on the remote host I was transferring from was pegged at 100% with the option enabled. After disabling it I see about 50-60% CPU utilization.
martin

Re: Wow

JimBurd wrote:

I appreciate the great product that the developers put out, but it sure seems like maybe this setting should be off by default (since it impacts so many different people).

Actually, we believe that the default makes it faster for most users.
JimBurd

Wow

I've struggled with slow speeds from my ESXi servers for years. I just thought that there was something going on with those servers that caused the slow speeds. I just found this thread today, and my transfer rates went from 400 KB/s to 25 MB/s.
I appreciate the great product that the developers put out, but it sure seems like maybe this setting should be off by default (since it impacts so many different people).
Netuddki

Did nothing for me.
I still download with 20kb/s on a 150 Gbit connection.
creechy

Check your Proxy command

I discovered for me, I was using a Proxy config to tunnel through a bastion host with plink. I converted that to use the built in Tunnel config and that sped up throughput immensely.
Gandalf68

Thanks, went from around 300 KB/s in a VM to 30MB/s using this... that's a 100X upgrade...
peeham

how

How do you access these settings? When I open my settings panel it doesn't have this sub-cat???
bmcquist

Re: can't find the settintgs

crazyluke wrote:

I have the same problem but can't fix it. Why?

I had some issues finding it as well. On the specific connection click the Advanced button and in the Advanced Site Settings window select Connection.
Under Connection uncheck Optimize connection buffer size.
kulps

Thanks

Disable connection optimization dramatically improved performance for me. Going from 400kbps to 4MB/s
crazyluke

can't find the settintgs

I have the same problem but can't fix it. Why?
gp

On 5.15 worked for me as well

Was getting ~ 300-400KB/s, to servers I knew could do better. Unchecked that box and immediately got 11MB/s to the same host.
Guest

Re: WinSCP slow speed SCP/SFTP - How I fixed it

MarcoP wrote:

Hi folks,

disable Connection -> Optimize connection buffer size.

Cheers

Awesome. This brought my local Ethernet performance from 750KB/s to 35MB/s(!!!)
martin

glenhall wrote:

i always noticed this with winscp, when i compare downloading something with filezilla or the old flashFXP client, winSCP always seemed slower as if it was capped, so im glad i found this subject here, but when i go into my site manager/advanced, i can see the optimize option but its greyed out and i cant untick it.
i have a passive option with can be ticked/unticked

The option is not available/relevant to FTP protocol.
glenhall

i always noticed this with winscp, when i compare downloading something with filezilla or the old flashFXP client, winSCP always seemed slower as if it was capped, so im glad i found this subject here, but when i go into my site manager/advanced, i can see the optimize option but its greyed out and i cant untick it.
i have a passive option with can be ticked/unticked
savvykong

martin wrote:

Equivalent to what?

A scripting equivalent to the "Optimize connection buffer size" checkbox in the GUI. But after reading through WinSCP documentation further I found what I was looking for - "SendBuf".
martin

savvykong wrote:

Is this a GUI only solution? I have a third party software workflow that utilizes WinSCP scripting under the hood. Would there be an equivalent setting in some config file somewhere? Thank you!

Equivalent to what?
savvykong

Is this a GUI only solution? I have a third party software workflow that utilizes WinSCP scripting under the hood. Would there be an equivalent setting in some config file somewhere? Thank you!
guest01

work for me

It works after I turned it off. It was about 800kb/s and now 32M/s. Thank you for your solution!
eddie4

Hahaha your lack of debugging disturbs me. As does your willingness to buy random hardware to solve your issue. This is a opensource project as is filezilla you should thank the developers not berate them when you have an issue.
reallyreally

re:

Spend like 300GBP for new switch because was thinking maybe my network issue tweak all setting on my gigabyte card update firmware.

Speed test show full gigabyte speed, but winscp (newest) was slow max 8-13MB/s 10 diffrent servers centos ubuntu xserver my datacenter backup dirffrent configuration scp sfpt ...

Then install FileZilla spft =====>>>> and get 32MB/s

This is official only one solution

You waste my time never in my life i will be use winscp !!!!!!!!!!!!!!!!!!
martin

OK, I've mentioned the option in the FAQ.
eddie4

This needs to be in the FAQ & perhaps a dev should take a look. Went from 300kb/s to 10,9MB/s (connection cap). This fixed my problem. HERO

EDIT:
This FAQ topic
https://winscp.net/eng/docs/faq_slow
Guest

Re: WinSCP slow speed SCP/SFTP - How I fixed it

MarcoP wrote:

Hi folks,

I changed most relevant settings but the one that actually worked was to disable Connection -> Optimize connection buffer size.


Thank You!
Guest

wow... this worked for me also. I was copy files on my LAN with scp and it topped out at 1200kb/s, and after I did this, I am now copying at 32MB/s.
Wildcat

Much faster here!

Worked for me here also. It is now several times faster than it was before I changed the setting.
mlazzarotto

Not working for me.
Versione 5.11
I noticed that SCP is much faster when transferring files.
martin

marcolussetti wrote:

Should this be noted on the FAQ entry for this?

Are you referring to some specific FAQ entry? Or are you asking for a new FAQ entry?
marcolussetti

I wanted to also thank the OP for the solution, and to note that my transfer speed went from ~550 KB/s to ~2.8 MB/s with no other changes but this single tweak. Should this be noted on the FAQ entry for this? I found it via FAQ -> Bug 164 -> Here, but I feel like not everyone would follow through that trail :)
martin

Re: WinSCP slow speed SCP/SFTP - How I fixed it

Thanks for sharing your solution.
MarcoP

WinSCP slow speed SCP/SFTP - How I fixed it

Hi folks,

old servers I knew were capped at 10Mb/s, so when WinSCP reported 1MB/s I was actually happy with it, so I stopped paying attention to it.

Recently I noticed that even from 1Gb/s and 100Mb/s servers, WinSCP was still downloading at 1MB/s so I got curious and then little frustrated when I noticed culprits were always the same servers, while others ranged from +4.5MB/s.

I changed most relevant settings but the one that actually worked was to disable Connection -> Optimize connection buffer size.

Cheers