Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Used protocol etc.

Louis2 wrote:

I am using SFTP and the very latest WinSCP version
Sincerely,

Thanks. Can you start a new thread and post a log file?
Louis2

Used protocol etc.

Hello,

I am using SFTP and the very latest WinSCP version
Sincerely,

Louis
martin

Re: WinSCP does not use CPU effective ==> slow

louis2 wrote:

When transfering a big systembackup file towards the NAS I noticed that the transfer rate was only about 640 gbit. I did at expect something like three to four times that.

So I looked at the cpu load of the nas (moderate intel Pentium g5460, 16GB) which was about 14% ….. and did have a look at the much more powerfull cpu here on my pc (AMD2700X 32GB). And up to my surprise my PC seems to be the limmiting factor ……

Thanks for your report.
What protocol are you using? What version of WinSCP?
louis2

WinSCP does not use CPU effective ==> slow

Hello,

I have a relatively fast freenas server connected via 10G with my PC.

When transfering a big systembackup file towards the NAS I noticed that the transfer rate was only about 640 gbit. I did at expect something like three to four times that.

So I looked at the cpu load of the nas (moderate intel Pentium g5460, 16GB) which was about 14% ….. and did have a look at the much more powerfull cpu here on my pc (AMD2700X 32GB). And up to my surprise my PC seems to be the limmiting factor ……

The taskmanager showed me that one of the possible 16 threads was at 100% all the time. No doubt that that was related to winscp …..

So there seems to be "some" room for improvement:
- starting with migratio to 64 bit
- and using multiple threads

I understand that you are using standard librarys …… but never the less I hope that you can improve things. By the way I did turn of the buffersize optimalisation, that was a slight improvement

Sincerely,

Louis
martin

Re: setting for latest version?

the corey's wrote:

the issue when I do it is that option is greyed out, how do I get passed that part?

The option is mostly relevant for SFTP and SCP protocols only. What protocol are you using?
the corey's

Re: setting for latest version?

martin wrote:

gsds2006@... wrote:

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?

I've posted a link at least twice above already.
https://winscp.net/eng/docs/ui_login_connection


the issue when I do it is that option is greyed out, how do I get passed that part?
martin

Re: setting for latest version?

gsds2006@... wrote:

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?

I've posted a link at least twice above already.
https://winscp.net/eng/docs/ui_login_connection
gsds2006@...

setting for latest version?

where does one find "Connection uncheck Optimize connection buffer size" setting for latest version? there's no connection settings listed on left like in the image?
nooneofconsequence

worked for me

I was getting about 10 KB/s with it enabled. Disabling it gets me to about 50 MB/s.
One difference I noted is that the CPU utilization on the remote host I was transferring from was pegged at 100% with the option enabled. After disabling it I see about 50-60% CPU utilization.
martin

Re: Wow

JimBurd wrote:

I appreciate the great product that the developers put out, but it sure seems like maybe this setting should be off by default (since it impacts so many different people).

Actually, we believe that the default makes it faster for most users.
JimBurd

Wow

I've struggled with slow speeds from my ESXi servers for years. I just thought that there was something going on with those servers that caused the slow speeds. I just found this thread today, and my transfer rates went from 400 KB/s to 25 MB/s.
I appreciate the great product that the developers put out, but it sure seems like maybe this setting should be off by default (since it impacts so many different people).
Netuddki

Did nothing for me.
I still download with 20kb/s on a 150 Gbit connection.
creechy

Check your Proxy command

I discovered for me, I was using a Proxy config to tunnel through a bastion host with plink. I converted that to use the built in Tunnel config and that sped up throughput immensely.
Gandalf68

Thanks, went from around 300 KB/s in a VM to 30MB/s using this... that's a 100X upgrade...
peeham

how

How do you access these settings? When I open my settings panel it doesn't have this sub-cat???
bmcquist

Re: can't find the settintgs

crazyluke wrote:

I have the same problem but can't fix it. Why?

I had some issues finding it as well. On the specific connection click the Advanced button and in the Advanced Site Settings window select Connection.
Under Connection uncheck Optimize connection buffer size.
kulps

Thanks

Disable connection optimization dramatically improved performance for me. Going from 400kbps to 4MB/s
crazyluke

can't find the settintgs

I have the same problem but can't fix it. Why?
gp

On 5.15 worked for me as well

Was getting ~ 300-400KB/s, to servers I knew could do better. Unchecked that box and immediately got 11MB/s to the same host.
Guest

Re: WinSCP slow speed SCP/SFTP - How I fixed it

MarcoP wrote:

Hi folks,

disable Connection -> Optimize connection buffer size.

Cheers


Awesome. This brought my local Ethernet performance from 750KB/s to 35MB/s(!!!)
martin

glenhall wrote:

i always noticed this with winscp, when i compare downloading something with filezilla or the old flashFXP client, winSCP always seemed slower as if it was capped, so im glad i found this subject here, but when i go into my site manager/advanced, i can see the optimize option but its greyed out and i cant untick it.
i have a passive option with can be ticked/unticked

The option is not available/relevant to FTP protocol.
glenhall

i always noticed this with winscp, when i compare downloading something with filezilla or the old flashFXP client, winSCP always seemed slower as if it was capped, so im glad i found this subject here, but when i go into my site manager/advanced, i can see the optimize option but its greyed out and i cant untick it.
i have a passive option with can be ticked/unticked
savvykong

martin wrote:

Equivalent to what?


A scripting equivalent to the "Optimize connection buffer size" checkbox in the GUI. But after reading through WinSCP documentation further I found what I was looking for - "SendBuf".
martin

savvykong wrote:

Is this a GUI only solution? I have a third party software workflow that utilizes WinSCP scripting under the hood. Would there be an equivalent setting in some config file somewhere? Thank you!

Equivalent to what?
savvykong

Is this a GUI only solution? I have a third party software workflow that utilizes WinSCP scripting under the hood. Would there be an equivalent setting in some config file somewhere? Thank you!
guest01

work for me

It works after I turned it off. It was about 800kb/s and now 32M/s. Thank you for your solution!
eddie4

Hahaha your lack of debugging disturbs me. As does your willingness to buy random hardware to solve your issue. This is a opensource project as is filezilla you should thank the developers not berate them when you have an issue.
reallyreally

re:

Spend like 300GBP for new switch because was thinking maybe my network issue tweak all setting on my gigabyte card update firmware.

Speed test show full gigabyte speed, but winscp (newest) was slow max 8-13MB/s 10 diffrent servers centos ubuntu xserver my datacenter backup dirffrent configuration scp sfpt ...

Then install FileZilla spft =====>>>> and get 32MB/s

This is official only one solution

You waste my time never in my life i will be use winscp !!!!!!!!!!!!!!!!!!
martin

OK, I've mentioned the option in the FAQ.
eddie4

This needs to be in the FAQ & perhaps a dev should take a look. Went from 300kb/s to 10,9MB/s (connection cap). This fixed my problem. HERO

EDIT:
This FAQ topic
https://winscp.net/eng/docs/faq_slow
Guest

Re: WinSCP slow speed SCP/SFTP - How I fixed it

MarcoP wrote:

Hi folks,

I changed most relevant settings but the one that actually worked was to disable Connection -> Optimize connection buffer size.


Thank You!
Guest

wow... this worked for me also. I was copy files on my LAN with scp and it topped out at 1200kb/s, and after I did this, I am now copying at 32MB/s.
Wildcat

Much faster here!

Worked for me here also. It is now several times faster than it was before I changed the setting.
mlazzarotto

Not working for me.
Versione 5.11
I noticed that SCP is much faster when transferring files.
martin

marcolussetti wrote:

Should this be noted on the FAQ entry for this?

Are you referring to some specific FAQ entry? Or are you asking for a new FAQ entry?
marcolussetti

I wanted to also thank the OP for the solution, and to note that my transfer speed went from ~550 KB/s to ~2.8 MB/s with no other changes but this single tweak. Should this be noted on the FAQ entry for this? I found it via FAQ -> Bug 164 -> Here, but I feel like not everyone would follow through that trail :)
martin

Re: WinSCP slow speed SCP/SFTP - How I fixed it

Thanks for sharing your solution.
MarcoP

WinSCP slow speed SCP/SFTP - How I fixed it

Hi folks,

old servers I knew were capped at 10Mb/s, so when WinSCP reported 1MB/s I was actually happy with it, so I stopped paying attention to it.

Recently I noticed that even from 1Gb/s and 100Mb/s servers, WinSCP was still downloading at 1MB/s so I got curious and then little frustrated when I noticed culprits were always the same servers, while others ranged from +4.5MB/s.

I changed most relevant settings but the one that actually worked was to disable Connection -> Optimize connection buffer size.

Cheers