Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


The issue is solved by the development version you sent me.
I can connect through the BackBlaze S3 API.

Many thanks!

Re: Unable to connect to Backblaze through S3 API

Thanks for your post.

This issue has been added to the tracker:

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

BackBlaze is only supporting AWS V4 signature process, not V2.

Is WinSCP capable of supporting V4 signing ? Is there any way in WinSCP to select V2 or V4 signing process; I couldn't find anything related in the Advanced site settings.

I'm using latest version of WinSCP on Windows 10.

Thanks, Bart

Somehow I managed to post as a guest...

Unable to connect to Backblaze through S3 API

BackBlaze announced a week ago they supports S3 API.
However, I'm unable to connect with WinSCP to BackBlaze. WinSCP comes back with following error message: "Connection failed. Invalid request parameter received: max-keys".
I made sure the API key has permission to list all buckets.
Could be user error of course, but I have no problems connecting to e.g. Wasabi with WinSCP.

Attached is the log file, hope you can see where the problems lies.
I took out the keys: I could supply them when required.

Thanks, Bart