Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Compressed/Zipped Files Getting Corrupted In Upload

Please attach a full session log file showing the upload, both from your and your coworker machine (using the latest version of WinSCP possible).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Adam C

Compressed/Zipped Files Getting Corrupted In Upload

Hi All,

I am having issues with using WinSCP to FTP compressed/zipped files to a secure remote site and would love some help if available.

The files upload correctly, but then after redownloading to my local environment, the files will not unzip, saying that the archive is corrupted. They are corrupted for other people who are downloading the files using different a methology too, so the corruption does not happen in the download process.

This does not happen for a coworker when he uses WinSCP to upload similar files to the same remote site and then redownload them for testing - the compressed files unzip fine in that scenario.

I am using SFTP protocol and Commander Interface, and have set the parameter to ensure that I am uploading a binary file. I have tried recreating the session file for our remote collaborator. I have tried uninstalling the WinSCP that I was using (v5.2) and reinstalling the same (older) version (v4.3.5) that my coworker uses. (And my employer has such tight software installation guidelines that WinSCP is effectively the only software that I can use for this file transfer task).

I'm using Windows 7.

Any suggestions as to things to check so as to now have this corruption happen will be welcome. Thanks.