Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: WinSCP GUI: FTP login failure due to PROFTP server

Your post is bit confusing. You mention SCP and FTP, which are not related in any way. Also what is puttyFTP? Can you login and browse folders using any other FTP client?

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Re: WinSCP GUI: FTP login failure due to PROFTP server

Sorry, I posted the issue above as a guest mistakenly since I couldn't tell whether I was logged in or not.

Anyways, I wanted to clarify that the '/mnt/username' folder does not exist, so the server is correctly seeing that it doesn't exist. I'm trying to figure out why winscp is causing to server to try that folder.

Thanks again.

WinSCP GUI: FTP login failure due to PROFTP server

Using WinSCP Version 5.9.6 (Build 7601) (OS 10.0.10240 - Windows 10 Enterprise 2015 LTSB):

While I'm able to login via SCP (SSH) to the server, attempting to login into the server's proftpd service fails. Its a FREENAS server. Server logs say 'chdir("/mnt/myusername"): No such file or directory. Clientside, the WINSCP log gives '530 Login incorrect.' as the error. I'm using passive mode since that's default.

Now, if I try to login via puttyFTP, it works fine & the remote directory is '/'. I'm a member of the wheel group on the server, so this isn't a problem.

For some reason, it seems like WINSCP is appending my username to the default '/mnt' path configured in proftp in FREENAS server. Is there someway to turn off this appending of the username.

I've not absolutely no luck in resolving this via many google searches and am quite surprised. That is the only reason I've resorted to creating a new post. I'm stumpted. Any help would be incredibly appreciated.