Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


WinSCP, FileZilla-server and FTPS passive mode

I struggled with file transfer in between WinSCP-client and FileZilla-server with FTPS-protocol with passive mode enabled.

To see what passive FTP means, see here: In short it means that FTP(s) server tells the client which TCP-port to use for file transfer. If you can log on to server, but cannot transfer files with FTP or FTPs protocol, this post is for you.

For some reason the FileZilla-server, in some cases, can tell incorrect IP address (=not the same as used to log on) for the passive data transfer. However, you can force WinSCP to use the same address by switching the "Force IP address for passive mode connections"-setting on. The documentation for that is here:

If you want to set the switch on for all FTP-sessions, you can set is as default e.g. like this:

  • Set the Configuration Storage to winscp.ini and open it (located in the same folder as winscp.exe and
  • Search for [Sessions\Default%20Settings] -section in winscp.ini. If you don't find it, create it.
  • Add FtpForcePasvIp=1 line to [Sessions\Default%20Settings] section.
  • Save and close winscp.ini.