Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

Advertisement

jsharma
Joined:
Posts:
8
Location:
India

Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client or at-least GIT Bash client.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
37,893
Location:
Prague, Czechia

Re: Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

I do not understand what you ask for. Can you please elaborate?

Reply with quote

jsharma

Re: Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

Windows have launched the WSL2 due to which now Windows support native Ubuntu Console. Also if you allow supporting the GIT BASH client instead of PUTTY which is very unproductive, then it will be great.

Reply with quote

kanlukasz
Joined:
Posts:
18

Re: Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

jsharma wrote:

allow supporting the GIT BASH client instead of PUTTY
This is very good idea

Reply with quote

martin
Site Admin
martin avatar

Re: Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

I know what WSL2 is.

But you didn't explain what do you ask for from WinSCP.

Reply with quote

Advertisement

jsharma
Joined:
Posts:
8
Location:
India

Re: Please allow the Support for Using Windows Terminal's Ubuntu machine as default Bash Client

I actually was requesting to allow adding the git-bash.exe path inside WinSCP using below Menu options:
Preferences > Integration > Applications

YMGDDw8t.png

Reply with quote

kizza42
Joined:
Posts:
3
Location:
Australia

Just an additional to this, I spent the day trying to get WinSCP to call the new Windows Terminal via wt.exe but it seems unable to launch that process. I ended up having to use the following command to fool Winscp in to being able to launch Windows Terminal:
C:\Windows\System32\cmd.exe /c "wt.exe" ssh.exe !U@!@ -p !#  -t "cd !/ ; /bin/bash"

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
37,893
Location:
Prague, Czechia

Indeed, due to the strange way the Windows Store app aliases are implemented, they are not recognized by WinSCP.
I've implemented a workaround for that:
https://winscp.net/tracker/1901
Though your syntax does not work for me. wt seems to misinterpret the semicolon. I had to escape it with a backslash:
wt.exe ssh.exe !U@!@ -p !#  -t "cd !/ \; /bin/bash"
I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

kizza42
Joined:
Posts:
3
Location:
Australia

Had a play with the test version and it calls Wt.exe and passes the arguments as expected Thankyou! 👍

I had to change my command line to be like yours
wt.exe ssh.exe !U@!@ -p !#  -t "cd !/ \; /bin/bash"

Reply with quote

Advertisement

SoftCreatR
Guest

SSH-Key?

While the Terminal integration works fine so far, it doesn't work, if you are using a private key in another directory than ~/.ssh.

Is there a way to use the key that is defined in the extended connection settings?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
37,893
Location:
Prague, Czechia

@SoftCreatR: WinSCP and OpenSSH use different key types. You cannot use WinSCP key for OpenSSH. It does not matter if the key is in ~/.ssh or not. I assume what you mean is it works, if the host works with default key in the default location (like ~/.ssh/id_rsa). If you want to use a different key, you would normally have to explicitly specify it using -i switch on the ssh commandline, right? In such case, edit ssh_config to configure a non-default key for the hosts that have their own keys.
Host example.com
  IdentityFile C:/path/key

Reply with quote

Advertisement

You can post new topics in this forum