Can't transfer - Treating files like they are directories

Advertisement

tjj
Joined:
Posts:
1

Can't transfer - Treating files like they are directories

Version 5.17.19
Sometime this morning WinSCP stopped working properly.
It appears to be treating everything on the source side (left pane) as a directory. If I transfer a file(L->R) with an existing file on the R, I get an error code 4 (which I believe is indicating it's trying to copy a directory that already exists).

If I transfer a file(L->R) that does not already exist on the R, I get a code 267 (invalid directory name) and it creates a directory on the R with the same name as my file.
Error retrieving file list for "Z:\m...\foo.pdf\*.*".
System Error. Code: 267.
The directory name is invalid
Transfers from R->L seem to work.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
37,863
Location:
Prague, Czechia

Re: Can't transfer - Treating files like they are directories

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Graywalker
Guest

Same issue

Relevant log entries:
. 2022-08-03 14:13:02.936 type=file;size=147456;modify=20140204234929.000;perms=awrfd; Profile.mdb
. 2022-08-03 14:13:02.936 type=file;size=1314816;modify=20120119001033.000;perms=awrfd; Support.mdb
. 2022-08-03 14:13:02.963 Source file timestamp is [2014-02-05T01:56:39.000Z], destination timestamp is [2014-02-05T01:56:39.000Z], will not overwrite
. 2022-08-03 14:13:02.963 Upload successful
* 2022-08-03 14:13:02.963 (ESkipFile) 
. 2022-08-03 14:13:02.963 File: '\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe' [2011-09-07T18:10:44.000Z] [102400]
* 2022-08-03 14:13:03.779 (EOSExtException) Error retrieving file list for "\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*".
* 2022-08-03 14:13:03.779 System Error.  Code: 267.
* 2022-08-03 14:13:03.779 The directory name is invalid
. 2022-08-03 14:13:03.779 Asking user:
. 2022-08-03 14:13:03.779 Error listing directory '\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*'. ("Error retrieving file list for ""\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*"".","System Error.  Code: 267.","The directory name is invalid")
< 2022-08-03 14:13:03.779 Script: Error listing directory '\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*'.
< 2022-08-03 14:13:03.780 Script: Error retrieving file list for "\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*".
 
< 2022-08-03 14:13:03.780 System Error.  Code: 267.
 
< 2022-08-03 14:13:03.780 The directory name is invalid
* 2022-08-03 14:13:03.784 (ESkipFile) Error listing directory '\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*'.
* 2022-08-03 14:13:03.784 Error retrieving file list for "\\server.mycompany.local\share\IntelliForms\Database\mdbDataTransfer.exe\*.*".
* 2022-08-03 14:13:03.784 System Error.  Code: 267.
* 2022-08-03 14:13:03.784 The directory name is invalid
. 2022-08-03 14:13:03.791 Copying finished: Transferred: 0, Elapsed: 0:01:19, CPS: 0/s
. 2022-08-03 14:13:03.791 Script: Failed
. 2022-08-03 14:13:03.791 Script: Exit code: 1
. 2022-08-03 14:13:03.792 Disconnected from server
Command being run via batch file :
"put \\server.mycompany.local\share\IntelliForms -resumesupport=on -resume -preservetime -neweronly" ^
ftpes, if that helps.

Would adding -transfer=automatic help? (trying that now)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
37,863
Location:
Prague, Czechia

Re: Same issue

@Graywalker: Thanks for your report.

This issue is being tracked here:
Bug 2056 – File on local network share treated as folder when uploading

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include a link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

You can post new topics in this forum