WinSCP 3.5 "remembers" remote password in saved sessions!

Advertisement

DMRosenblum
Joined:
Posts:
2
Location:
Teaneck, New Jersey, USA

WinSCP 3.5 "remembers" remote password in saved sessions!

I am using WinSCP 3.5.0 (Build 204) on a Windows XP system to connect to a HP/UX remote system. I have a single saved session for the HP/UX system, which I saved without entering my password. My intention was to type in my password each time I loaded that session, so my password would not be stored on my local system.

I find, however, that after I load the session, type in my password, login, do whatever file transfers I have to do, and quit, that the next time I use WinSCP and load that session, my password on the remote host has been saved. That is, my password appears typed in (hidden, of course, with bullets appearing instead of the actual password) in the password field, even though I have never saved the session with my password entered.

I do not like this behavior at all. I don't believe that passwords should be stored like that. How do I disable this remembering of my password? (By the way, I don't think this occurred in version 3.3.)

By the way, other than that, WinSCP is great!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: WinSCP 3.5 "remembers" remote password in saved sessions!

I suppose that you connect stored session by clicking "Load", entering password and than clicking "Login". This is known bug and will be fixed in the next release.

You can avoid it (and one step) by double-clicking stored session in the list. You'll be asked for password later, when server asks for it.
_________________
Martin Prikryl

Reply with quote

DMRosenblum
Joined:
Posts:
2
Location:
Teaneck, New Jersey, USA

Re: WinSCP 3.5 "remembers" remote password in saved sessions!

martin wrote:

I suppose that you connect stored session by clicking "Load", entering password and than clicking "Login". This is known bug and will be fixed in the next release.

You can avoid it (and one step) by double-clicking stored session in the list. You'll be asked for password later, when server asks for it.

Yes, you guessed exactly right. That's exactly how I connect. Thanks for the tip.

Reply with quote

Advertisement

You can post new topics in this forum