Topic "Get Command Within Script"

Author Message
[View user's profile]

Joined: 2011-08-26
Posts: 1
Location: Seattle
Trying to make a simple script work. I can delete my files locally, I can log in with winscp but when using the get command to retrieve the files from the remote host it does no work. Here is a kicker, when I run the script and log into the command prompt winscp, I can run the get command and it works just fine. I am missing something in my script. Need some help!! I am using the echo off and pause so I can watch the script work and once the scrit is working I will remove it.

Here is my script.

Session name is test
On the Winscp login session I do have the directories set to

I have tried using the *.*

Again it all works except the get files. What am I missing?

echo off
del D:\test123\class.csv
del D:\test123\students.csv
option batch on
option confirm off
"C:\Program Files (x86)\WinSCP\" test
set auto_name=1
set logfile=0
get /home/dennis/downloads/test/class.csv
get /home/dennis/downloads/test/students.csv
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26890
Location: Prague, Czechia
Please do not post the same question twice:
Martin Prikryl

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License