SFTP Upload - No Error Seen

Advertisement

mathsci
Joined:
Posts:
3
Location:
California

SFTP Upload - No Error Seen

I am having an isuse with the script below. I can connect to the vendor's server with my login credentials in either WinSCP or FileZilla but when I try the script from the command line
(winscp.exe /console /log /script=c:\C:\Program Files\WinSCP\myscript.txt), I see a flash and then nothing. I am opviously doing someting dumb, but cannot determine what it is after 6 hours looking at guides, etc. Since I have used WinSCP to do a transfer with a previous vendor who did not use a password, I suspect that is the problem.

Any assistance would be appreciated


WinSCP - 4.3.4 (Build 1428)
OS- Windows 2003 Server Std SP 2

================================================================
option batch on
option confirm off
open Username:password@company.com :22
option transfer binary
cd /
cd /home/delnorte
put C:\Local_Folder\contacts.txt
put C:\Local_Folder\courses.txt
put C:\Local_Folder\enrollment.txt
put C:\Local_Folder\mastschd.txt
put C:\Local_Folder\programs.txt
put C:\Local_Folder\roster.txt
put C:\Local_Folder\sites.txt
put C:\Local_Folder\studemo.txt
put C:\Local_Folder\terms.txt
put C:\Local_Folder\transcripts.txt
put C:\Local_Folder\users.txt
# Disconnect
close
# Exit WinSCP
exit

Reply with quote

mathsci
Joined:
Posts:
3
Location:
California

SFTP Upload - No Error Seen - Resolved

This is now working. I made 2 fairly dumb errors, both of which I should have figured out earlier.

In Scheduled Tasks, file paths have to be quoted since there are spaces in the paths (Program Files).

"C:\Program Files\WinSCP\WinSCP.exe" /console /script="C:\Program Files\WinSCP\myscript.txt" works.

The open command in the script has to be:

open sftp:username:password@company.com

The port augment I was using (:22) does not seem to work or be needed.

Hope this helps someone -

mathsci

PS - this is an EXCELLENT program - Thanks!

Reply with quote

Advertisement

You can post new topics in this forum