Connect Failure to Openssh_3.5p1 / Openssl 9.6.h

Advertisement

thebadmax
Joined:
Posts:
2
Location:
Austria/Styria/Leoben

Connect Failure to Openssh_3.5p1 / Openssl 9.6.h

Hello !
Today I first tried to use the Winscp2.1 (verson 1 gives a putty out of memory error) - and tried to connect to my 2 Linux Servers - both using openssh3.5p1, one compiled with openssl9.6g (were it works wonderful) and the other with openssl9.6h (doesn't work)

The thing I'm really wondering about is, that I can connect to both using putty0.53b, pagent and psftp (the putty scp command line client) without having any problems..
Further I tried exchanging the sshd_config file - but I didn't change anything...

I 'll attach the logfile, maybe any of you can tell me what went wrong, or maybe anyone can tell me what to do, 'cause I don't find anything wrong as the connection seems to be enabled..

thx, markus

Logfile :
[quote]
. --------------------------------------------------------------- -----------
. WinSCP Version 2.1.0 (Build 119)
. Login time: Mittwoch, 15. Januar 2003 15:32:43
. --------------------------------------------------------------- -----------
. Session name: max@193.170.29.193
. Host name: 193.170.29.193 (Port: 22)
. User name: max (Password: No, Key file: No)
. SSH protocol version: 2 only; Compression: No
. Agent forwarding: Yes; TIS/CryptoCard: No; KI: Yes
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping interval: 0 sec (0 = off); Timeout: 15 sec
. SSH Bugs: A,A,A,A,A,A,A,
. Proxy: none
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: default, EOL: 0
. Local directory: default, Remote directory: home, Update: No
. Clear aliases: Yes, Unset nat.vars: Yes
. Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------- -----------
. Looking up host "193.170.29.193"
. Connecting to 193.170.29.193 port 22
. Server version: SSH-2.0-OpenSSH_3.5p1
. We claim version: SSH-2.0-PuTTY-Local: Jan 12 2003 19:45:16
. Using SSH protocol version 2
. Doing Diffie-Hellman group exchange
. Doing Diffie-Hellman key exchange
. Host key fingerprint is:
. ssh-rsa 1024 7f:df:e1:ee:43:4a:0d:7a:c8:e8:27:78:0f:dd:17:9d
. Initialised AES-256 client->server encryption
. Initialised AES-256 server->client encryption
. Pageant is running. Requesting keys.
. Pageant has 0 SSH2 keys
. Keyboard-interactive authentication refused
. Sent password
. Access granted
. Opened channel for session
. Requesting OpenSSH-style agent forwarding
. Agent forwarding enabled
. Started a shell/command
. --------------------------------------------------------------- -----------
. Doing startup conversation with host (shell).
. Skipping host startup message (if any).
> echo "WinSCP: this is end-of-file:0"
< Last login: Wed Jan 15 15:30:41 from oeh-mac1
. Server sent command exit status 0
* (ESshFatal) Error skipping startup message.
. ---------------------------------------------------------------
[/quote]

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,540
Location:
Prague, Czechia

Re: Connect Failure to Openssh_3.5p1 / Openssl 9.6.h

Please make sure, that you have BASH set as default shell. It is does not help, please write me about any differences you know between two host of yours.
_________________
Martin Prikryl

Reply with quote

thebadmax
Joined:
Posts:
2
Location:
Austria/Styria/Leoben

Re: Connect Failure to Openssh_3.5p1 / Openssl 9.6.h

Hi !
(sers - k&ouml;nnten ja fast auf deutsch schreiben, aber das w&auml;re ja fies :-))
Thx - you just found the solution..
I didn't mention that till now 'cause the shell was set te default in both connections and it worked @the older one..

Wish a nice evening further on..

regards..
markus

Reply with quote

Advertisement

You can post new topics in this forum