Passwords do not get stored in WinSCP 5

Advertisement

Adambean
Guest

Passwords do not get stored in WinSCP 5

I'm having problems with stored passwords in WinSCP 5.0.0 (build 1431).

I use a master password, enter a password in the session form, ensure "Save password (protected by master password)" is ticked when saving the session. It prompts me for the master password and saves the session.

I can now connect without it asking me for the session (or master?) password. However after restarting WinSCP all saved passwords are lost.

Having checked the INI file (I use this over registry for roaming ability) the password tag on all the sessions is blank.

Reply with quote

Advertisement

Adambean
Adambean avatar
Joined:
Posts:
6
Location:
Cardiff, South Wales

Nice, I see that it has already been resolved.

Probably useless now but the OS is Windows 7 Professional x64, so the INI file for me is at %LocalAppData%\VirtualStore\Program Files (x86)\WinSCP

I also see there are quite a few unreleased changes. Do you offer a latest build download?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,205
Location:
Prague, Czechia

Adambean wrote:

Probably useless now but the OS is Windows 7 Professional x64, so the INI file for me is at %LocalAppData%\VirtualStore\Program Files (x86)\WinSCP
Note that this won't work in 5.0.1 anymore, as this version disables file virtualization:
https://winscp.net/tracker/719

I also see there are quite a few unreleased changes. Do you offer a latest build download?
No. But new version will be release soon.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

That means that you need to make sure you are running WinSCP from location where you have write permissions. Or that you need to specify alternative location for an INI file using /ini switch. There's actually nothing wrong on the article you refer to. But some note about the change might be worth it :)

Reply with quote

NicoHaase

What about the footnote? Version 4.x used the virtualstore without any other settings, and this was removed according to bug 519. So, I think, this should be removed from the wiki ;)

Reply with quote

Adambean
Adambean avatar
Joined:
Posts:
6
Location:
Cardiff, South Wales

martin wrote:

That means that you need to make sure you are running WinSCP from location where you have write permissions. Or that you need to specify alternative location for an INI file using /ini switch. There's actualy nothing wrong on the article you refer to. But some note about the change might be worth it :)
This won't be useful for multi-user computers.. I choose INI so it can be backed up, and sync'd to my file server so that I can get it immediately on my other computers.

Could we at least have the INI in %AppDir%\WinSCP if the process isn't running with UAC elevation?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,205
Location:
Prague, Czechia

Adambean wrote:

This won't be useful for multi-user computers.. I choose INI so it can be backed up, and sync'd to my file server so that I can get it immediately on my other computers.
So use the /ini switch.

Could we at least have the INI in %AppDir%\WinSCP if the process isn't running with UAC elevation?
INI file is target on portable use of WinSCP. E.g. from memory stick.

Reply with quote

Advertisement

Adambean
Adambean avatar
Joined:
Posts:
6
Location:
Cardiff, South Wales

martin wrote:

So use the /ini switch.
Didn't know about /ini
"C:\Program Files (x86)\WinSCP\WinSCP.exe" /ini="%AppData%\WinSCP\WinSCP.ini"
^ works brilliant, thanks.

Also saved passwords appear to re-load from the INI when using a master password (5.0.1 build 1449). Thanks for this fix :)

Reply with quote

Adambean
Adambean avatar

Hello and welcome to nearly 11 years ago. :)
Thanks for the update though, that's definitely a better default position for the INI file.
_________________
Thanks,

Adam Reece.

Reply with quote

Advertisement

You can post new topics in this forum