Date stamp changes when using script

Advertisement

myriad_rocker
Guest

Date stamp changes when using script

Hello all...I have a peculiar issue. When I use command prompt to transfer some zip files to Unix, all is well. Time stamps are maintained the same as they are on Windows. However, when I script them, the time stamps on two files are 13 hours in the past and one is just one hour in the past. I can't have this as I have a process on the Unix side that only uses files that came from that current day.

Any ideas why this is happening using scripting?

Reply with quote

Advertisement

myriad_rocker
Guest

Re: Date stamp changes when using script

myriad_rocker wrote:

Hello all...I have a peculiar issue. When I use command prompt to transfer some zip files to Unix, all is well. Time stamps are maintained the same as they are on Windows. However, when I script them, the time stamps on two files are 13 hours in the past and one is just one hour in the past. I can't have this as I have a process on the Unix side that only uses files that came from that current day.

Any ideas why this is happening using scripting?

I'm sorry, I spoke too soon. This happens no matter if I use a script or just manually use command prompt. Doesn't matter.

The files, in Windows, show one time and date. Once the files are on Unix, two files show 13 hours in the past and one shows 1 hour in the past.

:?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Date stamp changes when using script

Are you using the latest version of WinSCP? If not, please upgrade.

Also read this FAQ:
https://winscp.net/eng/docs/faq_timestamp

If neither helps, please send me an email, so I can send you back a debug version of WinSCP to track the problem. Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl

Reply with quote

Guest

Thanks for the reply, I appreciate it. Turns out it was a setting in WinSCP. I forget the exact name but it was basically a case where I told it to just leave the original file stamp time intact.

Reply with quote

Advertisement

You can post new topics in this forum